Bug 122465 - rpm -e <specificpackage> choking on other versions' dependencies
Summary: rpm -e <specificpackage> choking on other versions' dependencies
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-04 20:24 UTC by Moritz Barsnick
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 22:33:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Moritz Barsnick 2004-05-04 20:24:11 UTC
Description of problem:
I have multiple versions of a package installed - two kernels. Trying 
to uninstall one of them using "rpm -e", rpm refuses to do so because 
of dependencies of the _other_ package of the same name.

Version-Release number of selected component (if applicable):
4.3.1-0.3

How reproducible:
sometimes

Steps to Reproduce:
1. rpm -q kernel-smp
2. rpm -e kernel-smp-2.6.5-1.326
3.
  
Actual results:
1.
kernel-smp-2.4.22-1.2149.nptl
kernel-smp-2.6.5-1.326
2.
error: Failed dependencies:
        kernel = 2.4.22-1.2149-1sunshine.nptlsmp is needed by 
(installed) eagle-usb-de-modules-2.4.22_1.2149_1sunshine.nptlsmp-0.
6pre5-0.9sunshine
        kernel = 2.4.22-1.2149-1sunshine.nptlsmp is needed by 
(installed) alsa-driver-modules_2.4.22_1.2149_1sunshine.nptlsmp-1.0.
2a-0.2sunshine
        kernel = 2.6.5-1.319smp is needed by (installed) 
eagle-usb-de-modules-2.6.5_1.319smp-0.6pre5-0.10sunshine
        kernel >= 2.6.4-1.300 is needed by (installed) policy-1.11.
2-21
        kernel >= 2.6.4-1.300 is needed by (installed) 
policy-sources-1.11.2-21


Expected results:
rpm uninstalls kernel-smp-2.6.5-1.326, not worrying about other 
installed versions of kernel-smp

Additional info:
"--nodeps" is the workaround, for those who wouldn't have guessed so. 
;-)

Comment 1 Jeff Johnson 2004-05-04 22:33:25 UTC
Add --nodeps if you wish. Otherwise, this is a packaging, not an
rpm, problem. The dependencies are checked as specified in the packages
by rpm.


Note You need to log in before you can comment on or make changes to this bug.