Bug 122467 - <gettext-po.h>, libgettextpo.so* not packaged
<gettext-po.h>, libgettextpo.so* not packaged
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 16:38 EDT by Eido Inoue
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-08 19:55:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eido Inoue 2004-05-04 16:38:50 EDT
Description of problem:
Programmers that want to use the API/ABI provided by gettext to access
PO files from a C program currently cannot do so because the libraries
and headers are not packaged (only the .la file is packaged, which is
not useful by itself for development). 

Version-Release number of selected component (if applicable):
gettext-0.14.1-2.1

Steps to Reproduce:
1. rpm -ql gettext | grep -i libgettext
2. or alternatively, try to compile the sample code in gettext.info
   in the node libgettextpo

Additional info:
Other vendors RPMs do include the development files (see
rpmfind.net)-- although it could be debated as to whether they belong
in gettext or gettext-devel
Comment 1 Leon Ho 2004-05-24 01:04:02 EDT
We have been using --disable-shared for a while the *.so is not
included. I did not know the reason of previous maintainer disabling
it but i think it is good idea to include it. 

What do you think is favorable way to pacakge the *.so? Majority of
people do not need those API so I would think putting them into
gettext-devel maybe better. What do you think?
Comment 2 Eido Inoue 2004-05-24 12:27:10 EDT
Comment 1: as end users would never use them, libgettextpo.so* and the
gettext-po.h obviously belong in the subpackage gettext-devel
Comment 3 Leon Ho 2004-06-02 03:15:12 EDT
Thanks for the report! this should be fixed on 0.14.1. please confirm
the new package when you can.
Comment 4 Leon Ho 2004-06-02 03:16:12 EDT
s/0.14.1/0.14.1-3/
Comment 5 Eido Inoue 2004-06-02 11:46:49 EDT
I'm looking over 0.14.1-3 right now. There sure are a lot of files in
gettext-devel!

However, I've noticed something strange: the info pages in 0.14.1-3,
in the section "Manipulating PO files", no longer contains
documentation for libgettextpo! IOW, the menu item 

* libgettextpo::      Writing your own programs that process PO files

in gettext.info exists in 0.12.1-1, but not in 0.14.1-3 (which has
support for the API-- ironic)

Note You need to log in before you can comment on or make changes to this bug.