Bug 122477 - Trying to Log Out of Gnome/X Hangs System
Trying to Log Out of Gnome/X Hangs System
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-05-04 19:00 EDT by ensafi
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEL3 U5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-30 03:43:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X Configuration for HP zd7000 LCD (3.22 KB, text/plain)
2004-05-17 21:59 EDT, ensafi
no flags Details
X Log for HP zd7000 LCD (32.98 KB, text/plain)
2004-05-17 21:59 EDT, ensafi
no flags Details
System Log for HP zd7000 LCD (27.31 KB, text/plain)
2004-05-17 22:00 EDT, ensafi
no flags Details
X Configuration from XFree86 -configure (2.35 KB, text/plain)
2004-05-17 22:16 EDT, ensafi
no flags Details
X Log (31.26 KB, text/plain)
2004-05-17 22:17 EDT, ensafi
no flags Details
System Log (50.84 KB, text/plain)
2004-05-17 22:17 EDT, ensafi
no flags Details
X Log from XFree86 -configure (25.76 KB, text/plain)
2004-05-17 22:21 EDT, ensafi
no flags Details

  None (edit)
Description ensafi 2004-05-04 19:00:45 EDT
Description of problem:

I have an HP Pavilion zd7000 (ZD1881CL, 3.2 GHz Pentium 4, 512 MB 
RAM, 64 MB NVIDIA GeForce FX Go5700) running Red Hat Enterprise Linux 
ES v3 with al the latest updates. I have tried using both the 
standard "nv" driver that comes with RHEL and the latest "nvidia" 
driver from nVidia's web site. In both cases, when I try to log out 
of Gnome either by choosing "Log Out" from the menu or pressing Ctrl-
Alt-Del, the "Log Out" window appears, and the system locks up. The 
Caps Lock LED flashes, and the keyboard is dead. Sometimes, I can 
ping the system, and sometimes it's completely dead. In one instance 
I was able to login remotely, but for the most part, the system does 
not respons to remote logins, and I have to press the power button. 
Other than that, the system seems to work fine. The only way to exit 
Gnome safely is to hit Ctrl-Alt-F1 to return to the console where I 
started X, and then hit Ctrl-C to kill startx.

Version-Release number of selected component (if applicable):


How reproducible:

Almost always.

Steps to Reproduce:
1. Type "startx" at console to start Gnome session
2. Choose "Log Out" from menu
3. System will hang up as described above
Comment 1 Mike A. Harris 2004-05-05 19:45:38 EDT
While we do not support the proprietary "nvidia" driver, we will
try to troubleshoot the problem you're having while using the "nv"
driver and narrow it down.  It is important to note, that it is
possible this lockup problem could be a kernel issue, BIOS issue,
or some other issue also, however we'll proceed for now with the
assumption it is video related and see what we can determine.

I'll need you to do the following steps:

- Uninstall the proprietary Nvidia driver from your system at least

- Reinstall the Red Hat supplied XFree86 packages from the latest
  update.  This is important because the proprietary Nvidia driver
  installation overwrites several Red Hat supplied X server modules
  which can cause problems.

- Ensure that you have installed all updates released by Red Hat
  for RHEL 3 that have been released to date, and that you're using
  the latest official Red Hat binary kernel release.

- Reboot your system.  This step is necessary in order to force a
  total hardware reset of the video card, so that the "nv" driver
  is using the video hardware from it's factory default power on
  state, rather than after it's been reprogrammed by an alternate

- Run "system-config-display --reconfig" to generate a new config
  file which should be using the "nv" driver.  Ensure this is the
  driver chosen by examining the X server log file.

- Run the X server either via "startx" or via gdm/xdm/kdm

After X is started up using the "nv" driver as described above,
please gather the X server log /var/log/XFree86.0.log, the config
file /etc/X11/XF86Config, and your /var/log/messages file (including
at least all data since the system rebooted).  Attach these files
as individual uncompressed file attachments using the attachment
link below, and we will review the data and continue troubleshooting
from there.

Setting bug status to NEEDINFO.

Thanks in advance.
Comment 2 ensafi 2004-05-05 20:23:05 EDT
Thank you for your assistance.

I also suspected that the problem could be due to several other 
factors, but I had to start somewhere.  Here is one interesting 
point: the notebook has hyper-threading turned on, and there is no 
way to turn it off in the BIOS.  Does the latest stable RHEL support 
hyper-threading Penium 4 CPUs?  Whether or not it does, I have tried 
booting both the uni-processor and SMP kernels, and in both cases, 
Gnome/X still hangs when I try to log out.

I did notice something interesting today: if I don't move the mouse 
(actually the touchpad on the notebook) then I can hit Enter to log 
out of Gnome or use keyboard shortcuts to shut down the system.  I 
only repeated this twice, and then I had to send the notebook off on 
a business trip, so I am not sure how repeatably I can log out of 
Gnome without hanging the system if I don't move the mouse pointer.  
Perhaps I'll now more after our guys get back from the trip.

In any case, as soon as the notebook returns, I will do as you 
asked.  Also, just before the trip, I reinstalled RHEL from scratch 
and refrained from installing any third-party software or drivers, so 
the notebook now has a fresh, fully updated OS with standard-issue 

Once again, thank you for taking the time to look into this.
Comment 3 Mike A. Harris 2004-05-06 00:48:38 EDT
RHEL 3 supports hyperthreading on Pentium 4 CPUs.  I don't think
hyperthreading or SMP is related to the issue though.

The information about avoiding using the mouse is interesting.  There
could potentially be some kind of hardware conflict perhaps, or a bad
kernel driver causing the system to hang.  Could you test that out
by trying to log out several times without using the mouse and see
if it reproduceably avoids locking up?  That could help to establish
a bit of commonality to the lockups.

Your X server log, kernel log, and X config file may show
information about possible conflicts or kernel or hardware issues
perhaps.  I'll review this again once you've attached the details.

Thanks for the update.

Comment 4 ensafi 2004-05-17 21:59:01 EDT
Created attachment 100286 [details]
X Configuration for HP zd7000 LCD
Comment 5 ensafi 2004-05-17 21:59:50 EDT
Created attachment 100287 [details]
X Log for HP zd7000 LCD
Comment 6 ensafi 2004-05-17 22:00:09 EDT
Created attachment 100288 [details]
System Log for HP zd7000 LCD
Comment 7 ensafi 2004-05-17 22:01:39 EDT
The command "system-config-display" does not exist on any of our 
systems.  Instead, I regenerated a new /etc/X11/XF86Config 
using "XFree86 -configure".

In any case, we just upgraded to RHEL 3 ES Update 2, and the problem 
still persists.

I am attaching XF86Config_HP_zd7000, which is the X configuration I 
typically use (it basically adds a mode line for 1440x900@16bpp to 
support the wide LCD display at its highest resolution).  Log files 
containing "_HP_zd7000" correspond to this configuration, which 
caused the system to crash as usual upon displaying the "Log Out" 
window under Gnome.  The system was then rebooted, and I started X 
again with a newly regenerated XF86Config.  The corresponding logs 
are attached as you requested.
Comment 8 ensafi 2004-05-17 22:16:16 EDT
Created attachment 100289 [details]
X Configuration from XFree86 -configure
Comment 9 ensafi 2004-05-17 22:17:19 EDT
Created attachment 100290 [details]
X Log
Comment 10 ensafi 2004-05-17 22:17:38 EDT
Created attachment 100291 [details]
System Log
Comment 11 ensafi 2004-05-17 22:21:57 EDT
Created attachment 100292 [details]
X Log from XFree86 -configure

This is the log created when I ran "XFree86 -configure".  I thought it might be
useful.  I copied the automatically generated /root/XF86Config.new to
/etc/X11/XF86Config, and then I ran "startx".  The log files corresponding to
the X session are attached.
Comment 15 Mike A. Harris 2005-05-12 02:18:16 EDT
"redhat-config-xfree86" is the name of the config tool on RHEL3.  It was
renamed to "system-config-display" in newer operating system releases.

"X -configure" is known to generate bad config files for many systems,
and is thus not a supported configuration method.  Please reconfigure
the system by running:

    redhat-config-xfree86 --reconfig

Apologies for the command name mixup.

Using the stock config file, unmodified from what redhat-config-xfree86
produces, start the server, and if the problem is reproduceable, please
attach the file produced by "sysreport", as well as your X server log,
config file from this invocation.  Also attach the output of lsmod,
and /var/log/messages from this invocation.

I notice you're loading the "vnc" module in one config file, please leave
that out for these tests.  It's important to be able to narrow the problem
down.  We can then further narrow things down once we have this info.

Thanks in advance.
Comment 17 Mike Eklund 2005-05-31 13:44:13 EDT
You may not like this solution, but disabling the sound card modules in
modules.conf solves this problem for me.

Comment 18 Mike A. Harris 2005-08-30 03:43:56 EDT
Since there are insufficient details provided in this report for us
to investigate the issue further, and we have not received feedback
to the information we have requested above, we will assume the
problem was not reproduceable, or has been fixed in one of the
updates we have released for Red Hat Enterprise Linux 3.

Users who have experienced this problem are encouraged to upgrade
to the latest Red Hat Enterprise Linux update, and if this issue
turns out to still be reproduceable in the latest update, please
contact the Red Hat Global Support Services page on our
website for technical support options:  https://www.redhat.com/apps/support

If you have a telephone based support contract, you may contact
Red Hat at 1-888-REDHAT1 for technical support for the problem
you are experiencing.

Setting status to "CURRENTRELEASE"

Note You need to log in before you can comment on or make changes to this bug.