This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 122482 - ant rpm does not include "get" task
ant rpm does not include "get" task
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ant (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Permaine Cheung
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 20:14 EDT by Greg Wolfe
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:26:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Greg Wolfe 2004-05-04 20:14:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
The core task "get" is missing from both the "gcj'd" and "classic"
version of ant.  As a work-around, I can exec wget.

Version-Release number of selected component (if applicable):
ant-1.5.2-23

How reproducible:
Always

Steps to Reproduce:
1. write an ant build file that attempts to use the 'get task
http://ant.apache.org/manual/CoreTasks/get.html
2. run a target that uses the 'get' task
    

Actual Results:  The following error occurs:

 Could not create task or type of type: get.
 
Ant could not find the task or a class this task relies upon.
 
This is common and has a number of causes; the usual
solutions are to read the manual pages then download and
install needed JAR files, or fix the build file:
 - You have misspelt 'get'.
   Fix: check your spelling.
 - The task needs an external JAR file to execute
   and this is not found at the right place in the classpath.
   Fix: check the documentation for dependencies.
   Fix: declare the task.
 - The task is an Ant optional task and optional.jar is absent
   Fix: look for optional.jar in ANT_HOME/lib, download if needed
 - The task was not built into optional.jar as dependent
   libraries were not found at build time.
   Fix: look in the JAR to verify, then rebuild with the needed
   libraries, or download a release version from apache.org
 - The build file was written for a later version of Ant
   Fix: upgrade to at least the latest release version of Ant
 - The task is not an Ant core or optional task
   and needs to be declared using <taskdef>.


Expected Results:  The get task should fetch content from a url

Additional info:

From browsing through the internet, it appears that this task may have
intentionally been excluded because it attempts to use a sun.* class
(Base64).

This reason is a bit bogus because the code for the Get task in ant
1.6.1 attempts to use the sun.* class only if it is found via
Class.forName() and otherwise uses it's own Base64 class.
Comment 1 RHEL Product and Program Management 2007-10-19 15:26:43 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.