Bug 122507 - USB disconnect/reconnect of keyboard & mouse on KVM fails sporadically
USB disconnect/reconnect of keyboard & mouse on KVM fails sporadically
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 06:45 EDT by Adam Wiggins
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 05:54:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Wiggins 2004-05-05 06:45:22 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
I have a KVM that I use for switching back and forth between my G5 
and my Linux box.  It handles keyboard & mouse by acting as a USB hub 
that just disconnects from one system and reconnects to the other 
when I switch it.  I've been using this setup for a while now without 
any difficulty on Debian with kernel version 2.4. 
 
Since switching to Fedora 2 test 3, the switch fails about 80% of the 
time coming over the to the Linux box.  (The Mac always reconnects 
properly.)  All I can do is switch back and forth randomly until the 
caps lock key on the keyboard comes on, indiciating a reconnect. 
 
I did dmesg -c before a switch to see what would happen.  Here's what 
was in the logs by the time I got it to properly reconnect again: 
 
usb 3-2: USB disconnect, address 29 
usb 3-2.1: USB disconnect, address 30 
usb 3-2.3: USB disconnect, address 31 
usb 3-2: new full speed USB device using address 32 
hub 3-2:1.0: USB hub found 
hub 3-2:1.0: 3 ports detected 
usb 3-2.1: new low speed USB device using address 33 
input: USB HID v1.10 Mouse [Logitech USB Mouse] on 
usb-0000:00:10.1-2.1 
usb 3-2.3: new full speed USB device using address 34 
input: USB HID v1.10 Keyboard [Mitsumi Electric Apple Extended USB 
Keyboard] on usb-0000:00:10.1-2.3 
input: USB HID v1.10 Device [Mitsumi Electric Apple Extended USB 
Keyboard] on usb-0000:00:10.1-2.3 
 
 
Version-Release number of selected component (if applicable): 
hotplug-2004_03_11-1 
 
How reproducible: 
Sometimes 
 
Steps to Reproduce: 
Should be reproducable by just plugging and unplugging a USB keyboard 
a few times.
Comment 1 Adam Wiggins 2004-06-14 05:54:39 EDT
Upgraded to FC2 (non-test) and have not encountered again. 

Note You need to log in before you can comment on or make changes to this bug.