Bug 122538 - Rebuilding dies at patches applying if SELinux is turned off
Rebuilding dies at patches applying if SELinux is turned off
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
: EasyFix, SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 12:38 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 18:43:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
util-linux.spec.diff (927 bytes, text/plain)
2004-05-13 16:06 EDT, Robert Scheck
no flags Details
util-linux-2.11z-03-krb5.patch (7.96 KB, patch)
2004-05-13 16:08 EDT, Robert Scheck
no flags Details | Diff
util-linux-2.12-nfssloppy.patch (1021 bytes, patch)
2004-05-13 16:09 EDT, Robert Scheck
no flags Details | Diff
mount-2.11y-selinux.patch (1.70 KB, patch)
2004-05-13 16:09 EDT, Robert Scheck
no flags Details | Diff
util-linux.spec.diff (1.20 KB, patch)
2004-06-26 14:08 EDT, Robert Scheck
no flags Details | Diff
mount-2.11y-selinux.patch (1.71 KB, patch)
2004-06-26 14:08 EDT, Robert Scheck
no flags Details | Diff
util-linux-2.12-nfssloppy.patch (1.35 KB, patch)
2004-06-26 14:09 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2004-05-05 12:38:33 EDT
Description of problem:
Rebuilding dies at patches applying if SELinux is turned off:

--- snipp ---
Patch #1020 (util-linux-2.11z-03-krb5.patch):
+ patch -p1 -b --suffix .krb5 -s
+ echo 'Patch #1040 (util-linux-2.12-nfs-mount.patch):'
Patch #1040 (util-linux-2.12-nfs-mount.patch):
+ patch -p1 -b --suffix .nfsmount -s
+ echo 'Patch #1001 (util-linux-2.12-nfssloppy.patch):'
Patch #1001 (util-linux-2.12-nfssloppy.patch):
+ patch -p1 -b --suffix .nfssloppy -s
2 out of 5 hunks FAILED -- saving rejects to file mount/nfsmount.c.rej
error: Bad exit status from /var/tmp/rpm-tmp.6940 (%prep)
--- snapp ---

Version-Release number of selected component (if applicable):
util-linux-2.12-18

How reproducible:
Everytime

Steps to Reproduce:
1. Get util-linux-2.12-18 from Fedora Development
2. Turn SELinux off
3. Rebuild it
4. Get the error
  
Actual results:
There has to be a better patch merging, that the patch applying works
everytime. I think the SELinux patch should be the last patch, that
is applied to avoid problems like this.

Expected results:
Rebuilding should work with and without SELinux support.
Comment 1 Elliot Lee 2004-05-13 15:07:46 EDT
Unfortunately, this type of change is not a high priority right now,
since SELinux is the future. You'll have to send a patch if you want
this to happen.
Comment 2 Robert Scheck 2004-05-13 16:04:31 EDT
Why did I already know that before? ;-)

Okay, the following changes make it working for me for both:
Comment 3 Robert Scheck 2004-05-13 16:06:02 EDT
Created attachment 100218 [details]
util-linux.spec.diff
Comment 4 Robert Scheck 2004-05-13 16:08:40 EDT
Created attachment 100219 [details]
util-linux-2.11z-03-krb5.patch
Comment 5 Robert Scheck 2004-05-13 16:09:14 EDT
Created attachment 100220 [details]
util-linux-2.12-nfssloppy.patch
Comment 6 Robert Scheck 2004-05-13 16:09:37 EDT
Created attachment 100221 [details]
mount-2.11y-selinux.patch
Comment 7 Elliot Lee 2004-05-26 18:50:26 EDT
As of util-linux-2.12a the SELinux patches are integrated into the
upstream sources, so turning off SELinux no longer makes sense for the
FC devel version.

Eek, and you did all that work too - I'm sorry! If there's still a
need to turn off selinux we can figure something out.
Comment 8 Robert Scheck 2004-06-26 14:06:31 EDT
Reopening, because that closing reason was only a nice alibi, 
Elliot... :-(

Turning off or on SELinux makes also sense for util-linux-2.12a at 
Fedora Core development.

I know, that non SELinux hasn't a high priority, so I did some patch
merging myself (as I already did it for 2.12) - working for me - and 
attaching them here, again.

Maybe you can apply now these changes really and not defer them? That 
would be very nice, thank you :-)
Comment 9 Robert Scheck 2004-06-26 14:08:14 EDT
Created attachment 101439 [details]
util-linux.spec.diff
Comment 10 Robert Scheck 2004-06-26 14:08:48 EDT
Created attachment 101440 [details]
mount-2.11y-selinux.patch
Comment 11 Robert Scheck 2004-06-26 14:09:32 EDT
Created attachment 101441 [details]
util-linux-2.12-nfssloppy.patch
Comment 12 Elliot Lee 2004-08-31 18:43:48 EDT
Sorry, I don't see the point anymore. Turning off SELinux feature
compilation doesn't make sense for Fedora Core development especially
since SELinux is on by default, so I don't see that there's still a
need for turning SELinux off. We can talk about it on IRC if you like.

Note You need to log in before you can comment on or make changes to this bug.