Bug 122541 - writefd_unbuffered failed to write...
writefd_unbuffered failed to write...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 13:04 EDT by mark
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 13:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark 2004-05-05 13:04:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
the zip drive is a firewire iomega 750mb drive...

[root@markf78 zip750]# rsync -vr /home/zip750 /mnt/zip/zip750
building file list ... done
zip750/#canadienkings.txt#
zip750/C/2b.c
zip750/C/fileio.h
zip750/C/hash.c
zip750/C/hash.h
zip750/C/httpfn.c
zip750/C/httpfn.h
zip750/C/random.c
zip750/C/random.h
zip750/C/stringfn.c
zip750/C/stringfn.h
zip750/C/tcpsocket.c
zip750/C/tcpsocket.h
zip750/JPEGs/Diploma.jpg

(snip)

zip750/backups/Linux/Xmms/xmms-1.2.10-1.i386.rpm
zip750/backups/Linux/Xmms/xmms-alsa-1.2.10-1.i386.rpm
zip750/backups/Linux/dd_rescue-1.03.tar.gz
zip750/backups/Linux/ghex-2.4.0.1-0.fdr.4.1.i386.rpm
zip750/backups/Linux/kernel-2.6.3-2.1.253.2.1.i686.rpm
zip750/backups/Linux/modprobe.conf

mkstemp "/mnt/zip/zip750/zip750/C/.2b.c.v2TNLo" failed: No such file or
directory

zip750/backups/Macintosh/.DS_Store
zip750/backups/Macintosh/Connectix Virtual PC 6.0.sit
zip750/backups/Macintosh/RealOnePlayerGold.sit
zip750/backups/Macintosh/serial number.rtf
zip750/backups/Windows/AdbeRdr60_enu_full.exe
zip750/backups/Windows/Dell BIOS vA10.exe.gz
zip750/backups/Windows/DirectX 8.1.exe
zip750/backups/Windows/GoogleToolbarInstaller.exe
zip750/backups/Windows/MPEG-4 v1.1.exe
zip750/backups/Windows/QuickTime 6.4.exe
zip750/backups/Windows/Windows Media Player v9 Runtime.exe
zip750/backups/Windows/ie4.zip

rsync: writefd_unbuffered failed to write 4 bytes: phase "unknown":
Broken pipe
rsync error: error in rsync protocol data stream (code 12) at io.c(836)
rsync: writefd_unbuffered failed to write 69 bytes: phase "unknown":
Broken
pipersync error: error in rsync protocol data stream (code 12) at
io.c(836)

i can duplicate it every time...

[root@markf78 zip750]# rpm -q rsync
rsync-2.6.2-0



Version-Release number of selected component (if applicable):
rsync-2.6.2-0

How reproducible:
Always

Steps to Reproduce:
1. see description
2.
3.
    

Actual Results:  see description

Expected Results:  works as intended

Additional info:
Comment 1 mark 2004-06-14 13:24:42 EDT
this was resulting from a lack of space for temp files. resolved by
using the --temp-dir switch.

Note You need to log in before you can comment on or make changes to this bug.