Bug 12257 - mkinitrd fails with 'alias scsi_hostadapterX unknown'
mkinitrd fails with 'alias scsi_hostadapterX unknown'
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-14 11:19 EDT by Matt Domsch
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-26 12:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2000-06-14 11:19:42 EDT
mkinitrd fails when the /etc/conf.modules file contains a line such as:
alias scsi_hostadapterX unknown
because 'unknown' isn't a valid SCSI module.
This patch adds unknown to the list of PRESCSIMODS, so it's failure to 
exist is ignored.

--- /sbin/mkinitrd.orig	Wed Jun 14 05:02:41 2000
+++ /sbin/mkinitrd	Wed Jun 14 05:02:50 2000
@@ -31,7 +31,7 @@
 else
   IMAGESIZE=1500
 fi
-PRESCSIMODS="scsi_mod sd_mod"
+PRESCSIMODS="scsi_mod sd_mod unknown"
 fstab="/etc/fstab"
 
 usage () {
Comment 1 Bill Nottingham 2000-06-14 12:00:15 EDT
Was this an upgrade or a fresh install (i.e., did something
in the new beta *put* the unknown entry there?)
Comment 2 Matt Domsch 2000-06-14 12:14:15 EDT
Fresh install of 6.2 SBE2 with a new RAID card from AMI.  It has two qlogic 
12160 controllers behind a bridge, and kudzu had "unknown" as the driver for 
the 12160s or the bridge, I don't recall which.  In any case, something (either 
anaconda or kudzu) wrote into conf.modules wrong, which then caused mkinitrd to 
fail.  Fixing anaconda and/or kudzu is good, but catching it in mkinitrd 
regardless would be good too.  Since mkinitrd had not been patched in Winston 
Beta 1, I put it there.
Comment 3 Bill Nottingham 2000-06-14 17:19:08 EDT
OK, kudzu should already be fixed for this case; it's
just not pushed back to 6.2SBE2.
Comment 4 Bill Nottingham 2000-06-26 12:23:55 EDT
Fixed in mkinitrd-2.4.4.

Note You need to log in before you can comment on or make changes to this bug.