Bug 122570 - autoconf thinks x86_64-linux is an invalid host
Summary: autoconf thinks x86_64-linux is an invalid host
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autoconf213 (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Reed
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-05 21:02 UTC by H.J. Lu
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 21:11:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A testcase (646 bytes, application/octet-stream)
2004-08-20 16:28 UTC, H.J. Lu
no flags Details

Description H.J. Lu 2004-05-05 21:02:08 UTC
I got

# /export/gnu/src/gcc/gcc/configure x86_64-linux
configure: warning: x86_64-linux: invalid host type

The problem is /usr/share/autoconf-2.13/acgeneral.m4 has

changequote(, )dnl
    if test -n "`echo $ac_option| sed 's/[-a-z0-9.]//g'`"; then
changequote([, ])dnl
      AC_MSG_WARN($ac_option: invalid host type)
    fi

which means '_' can't be the part of a valid host type.

Comment 1 Jens Petersen 2004-05-06 07:03:51 UTC
Does "configure" fail too without an arch argument?

Comment 2 H.J. Lu 2004-05-06 15:26:37 UTC
Configure never fails. It just complains. If you don't provide an
arch argument, it won't complain. The simple fix is to change

if test -n "`echo $ac_option| sed 's/[-a-z0-9.]//g'`"; then

to

if test -n "`echo $ac_option| sed 's/[-a-z0-9._]//g'`"; then
                                              ^

Comment 3 H.J. Lu 2004-06-24 16:38:13 UTC
RHEL 4 A3 has the same problem.

Comment 4 Daniel Reed 2004-08-20 04:01:40 UTC
Is current autoconf failing to produce configure scripts that handle
x86_64, or are we distributing some software that has this problem due
to its being packaged with an older autoconf?

Comment 5 H.J. Lu 2004-08-20 14:41:08 UTC
It is a warning, not a fatal error. This patch

--- acgeneral.m4        2004-02-15 03:19:59.000000000 -0800
+++ acgeneral.m4        2004-08-20 07:42:35.677767934 -0700
@@ -552,7 +552,7 @@ changequote([, ])dnl
  
   *)
 changequote(, )dnl
-    if test -n "`echo $ac_option| sed 's/[-a-z0-9.]//g'`"; then
+    if test -n "`echo $ac_option| sed 's/[-a-z0-9._]//g'`"; then
 changequote([, ])dnl
       AC_MSG_WARN($ac_option: invalid host type)
     fi

fixes it.

Comment 6 Daniel Reed 2004-08-20 16:04:30 UTC
Is current autoconf failing to produce configure scripts that handle
x86_64 without warnings, or are we distributing some software that has
this problem due to its being packaged with an older autoconf?

It is not clear to me if this is an autoconf problem or a problem with
other software's autotooled packaging.

Comment 7 H.J. Lu 2004-08-20 16:28:48 UTC
Created attachment 102930 [details]
A testcase


[hjl@gnu-64 autoconf]$ make
autoconf-2.13
./configure x86_64-linux
configure: warning: x86_64-linux: invalid host type
loading cache ./config.cache
configure: error: can not find install-sh or install.sh in . ./.. ./../..
make: *** [all] Error 1

The warning

configure: warning: x86_64-linux: invalid host type

shouldn't be there.

Comment 8 Daniel Reed 2004-08-20 18:25:59 UTC
Would it be possible for the software in question to be migrated to
the current autoconf 2.5 tree? The autoconf package's "autoupdate"
utility may be especially helpful for this.

I do not believe the autoconf213 tree is maintained upstream, and I am
not convinced we should take over maintenance of 2.1 given the feature
similarities between 2.1 and 2.5 (the latter of which *is* under
active development).

Comment 9 H.J. Lu 2004-08-20 19:01:27 UTC
It is just a warning and doesn't affect outputs. It is up to
you to decide if you want to apply the patch or not.

Comment 10 Daniel Reed 2004-08-24 21:11:10 UTC
autoconf213 is "frozen" for anything but critical bugs.

If you need help porting older software to the current autoconf, I
would be happy to answer any specific problems you might have. You may
also contact the <autoconf@gnu.org> mailing list for assistance.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.