Bug 1225749 - Missing dependency libQt5Sensors.so.5 and libQt5Positioning.so.5 due to 3rd party rpms: hipchat, rstudio, viber
Summary: Missing dependency libQt5Sensors.so.5 and libQt5Positioning.so.5 due to 3rd p...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Keywords: CommonBugs
: 1226984 1291101 1424830 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-28 07:43 UTC by Karl Fischer
Modified: 2017-02-20 16:10 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-05-28 14:01:25 UTC


Attachments (Terms of Use)
Screenshot of the error (123.00 KB, image/png)
2015-05-28 07:43 UTC, Karl Fischer
no flags Details

Description Karl Fischer 2015-05-28 07:43:09 UTC
Created attachment 1031066 [details]
Screenshot of the error

Description of problem: Install Calibre on Fedora 22 64bit, fails to launch because of a missing dependency, libQt5Sensors.so.5


Version-Release number of selected component (if applicable):
calibre-2.27.0-1.fc22.x86_64
How reproducible:


Steps to Reproduce:
1.dnf install calibre
2.run calibre 
3. fails looking for dependency

Actual results:
[kmf@piggy Music] $ calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib64/calibre/calibre/gui_launch.py", line 62, in calibre
    main(args)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 511, in main
    gui_debug=gui_debug)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 357, in run_gui
    from calibre.gui2.ui import Main
  File "/usr/lib64/calibre/calibre/gui2/ui.py", line 40, in <module>
    from calibre.gui2.init import LibraryViewMixin, LayoutMixin
  File "/usr/lib64/calibre/calibre/gui2/init.py", line 18, in <module>
    from calibre.gui2.library.views import BooksView, DeviceBooksView
  File "/usr/lib64/calibre/calibre/gui2/library/views.py", line 17, in <module>
    from calibre.gui2.library.delegates import (RatingDelegate, PubDateDelegate,
  File "/usr/lib64/calibre/calibre/gui2/library/delegates.py", line 23, in <module>
    from calibre.gui2.dialogs.comments_dialog import CommentsDialog
  File "/usr/lib64/calibre/calibre/gui2/dialogs/comments_dialog.py", line 8, in <module>
    from calibre.gui2.dialogs.comments_dialog_ui import Ui_CommentsDialog
  File "/usr/lib64/calibre/calibre/gui2/dialogs/comments_dialog_ui.py", line 41, in <module>
    from calibre.gui2.comments_editor import Editor
  File "/usr/lib64/calibre/calibre/gui2/comments_editor.py", line 17, in <module>
    from PyQt5.QtWebKitWidgets import QWebView, QWebPage
ImportError: libQt5Sensors.so.5: cannot open shared object file: No such file or directory


Expected results:
Should launch without issues

Additional info:

fixed by "dnf install -y qt5-qtsensors-5.4.1-2.fc22.i686"

Comment 1 Karl Fischer 2015-05-28 08:02:29 UTC
fixed by dnf install -y qt5-qtsensors qt5-qtlocation

these should be dependencies

Comment 2 Kevin Fenzi 2015-05-28 11:36:30 UTC
calibre requires python-qt5, which in turn requires both those libraries. 

Can you provide output of: 

rpm -q python-qt5 

rpm -V python-qt5

rpm -q --whatprovides 'libQt5Sensors.so.5()(64bit)'

I suspect you may have a poorly packaged 3rd party rpm that claims to provide those libraries, but doesn't really.

Comment 3 Karl Fischer 2015-05-28 13:58:56 UTC
[kmf@piggy ~] $ rpm -q python-qt5
python-qt5-5.4.1-1.fc22.x86_64

[kmf@piggy ~] $ rpm -V python-qt5

[kmf@piggy ~] $ rpm -q --whatprovides 'libQt5Sensors.so.5()(64bit)'
hipchat-2.2.1373-1.x86_64
qt5-qtsensors-5.4.1-2.fc22.x86_64

Comment 4 Karl Fischer 2015-05-28 13:59:54 UTC
guess it's the Hipchat .... I'll address it with Atlassian

Comment 5 Kevin Fenzi 2015-05-28 14:01:25 UTC
Yep. We have seen this before. ;( 

If you find a place to submit a bug or the like, please let me know. I'd be happy to explain to them how to fix their package. ;)

Comment 6 Rex Dieter 2015-06-02 17:43:03 UTC
updating summary

Comment 7 Rex Dieter 2015-06-02 18:09:19 UTC
Related social media (g+) post on the topic,
https://plus.google.com/+RexDieter/posts/7awPKg4Mgw2

Comment 8 Rex Dieter 2015-06-29 11:54:28 UTC
*** Bug 1226984 has been marked as a duplicate of this bug. ***

Comment 9 Rex Dieter 2015-12-14 14:00:06 UTC
*** Bug 1291101 has been marked as a duplicate of this bug. ***

Comment 11 Rex Dieter 2016-12-23 15:50:03 UTC
And hipchat, confirmed still broken as of today,
https://answers.atlassian.com/questions/37857289/love-hipchat4---will-you-be-providing-rpms-for-it

Comment 12 Rex Dieter 2017-02-20 16:10:50 UTC
*** Bug 1424830 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.