Bug 1225998 - Tap-and-drag touchpad behavior not configurable
Summary: Tap-and-drag touchpad behavior not configurable
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 22
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 1226529 1227990 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-28 17:19 UTC by Jesse Kennedy
Modified: 2015-08-10 01:38 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-06-07 16:03:42 UTC


Attachments (Terms of Use)

Description Jesse Kennedy 2015-05-28 17:19:36 UTC
Description of problem:
It appears that the touchpad tap-and-drag behavior in libinput is not configurable. In the old synaptics driver and Windows, releasing your finger after a tap-and-drag gesture released the cursor button immediately. The new libinput 

Version-Release number of selected component (if applicable):
libinput-0.15.0-1.fc22.x86_64

How reproducible:


Steps to Reproduce:
1. Double tap and hold
2. Move finger to desired position
3. Release

Actual results:
Cursor button stays in pressed position until a timeout value.

Expected results:
Cursor button is released immediately if configured.

Additional info:
https://bugs.freedesktop.org/show_bug.cgi?id=90255
https://bugzilla.redhat.com/show_bug.cgi?id=1181565

Comment 1 Veske 2015-05-28 19:29:35 UTC
The description here is a bit off but I can overally confirm that we have a bug here.

Documentation is here: http://wayland.freedesktop.org/libinput/doc/latest/tapping.html

It say's that when you want to tap-drag something, you have to do a second tap after dragging, to end the dragging. But that second tap to cancel dragging is not working.

In any case this new feature seems akwardly implemented, it should be left for the user to choose how they want the touch gestures to work.

Comment 2 Peter Hutterer 2015-05-29 01:58:31 UTC
(In reply to Veske from comment #1)
> The description here is a bit off but I can overally confirm that we have a
> bug here.
> 
> Documentation is here:
> http://wayland.freedesktop.org/libinput/doc/latest/tapping.html
>
> It say's that when you want to tap-drag something, you have to do a second
> tap after dragging, to end the dragging. But that second tap to cancel
> dragging is not working.

that's the documentation for current git master, the feature was merged after 0.15 which is the one in F22 atm. 0.16 should be out next week, I hope.

> In any case this new feature seems akwardly implemented, it should be left
> for the user to choose how they want the touch gestures to work.

every configuration option ends up in a combinatorial explosion of test case. and we'd honestly rather provide behaviour that we know works than a bunch of config options that have undefined interactions.

Comment 3 Fedora Update System 2015-05-29 02:16:17 UTC
libinput-0.15.0-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libinput-0.15.0-4.fc22

Comment 4 Jesse Kennedy 2015-05-29 15:10:06 UTC
(In reply to Peter Hutterer from comment #2)
> (In reply to Veske from comment #1)
> > The description here is a bit off but I can overally confirm that we have a
> > bug here.
> > 
> > Documentation is here:
> > http://wayland.freedesktop.org/libinput/doc/latest/tapping.html
> >
> > It say's that when you want to tap-drag something, you have to do a second
> > tap after dragging, to end the dragging. But that second tap to cancel
> > dragging is not working.
> 
> that's the documentation for current git master, the feature was merged
> after 0.15 which is the one in F22 atm. 0.16 should be out next week, I hope.
> 
> > In any case this new feature seems akwardly implemented, it should be left
> > for the user to choose how they want the touch gestures to work.
> 
> every configuration option ends up in a combinatorial explosion of test
> case. and we'd honestly rather provide behaviour that we know works than a
> bunch of config options that have undefined interactions.

That's fine, but the new behavior is a departure what most users are used to. I should have written the description better, but I'm just asking for a customizable timeout value. This would allow users to preserve the old behavior.

Comment 5 Veske 2015-05-29 15:26:45 UTC
Gave the new Fedora 22 to a couple of tech illeterate people, they took the tap-to-drag new behaviour as something that was completely broken.

I don't think that new people should be forced to learn new ways to handle the most basic tasks in computing.

Comment 6 Fedora Update System 2015-05-30 15:37:38 UTC
Package libinput-0.15.0-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libinput-0.15.0-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9063/libinput-0.15.0-4.fc22
then log in and leave karma (feedback).

Comment 7 Striker Leggette 2015-05-31 00:31:34 UTC
Thank you.  0.15.0-4 corrects the behavior of -tap-to-release-.

Comment 8 Fedora Update System 2015-06-02 03:54:33 UTC
libinput-0.16.0-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libinput-0.16.0-3.fc22

Comment 9 Fedora Update System 2015-06-02 08:19:08 UTC
libinput-0.16.0-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libinput-0.16.0-4.fc22

Comment 10 Fedora Update System 2015-06-02 15:16:19 UTC
libinput-0.15.0-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Jesse Kennedy 2015-06-02 16:16:46 UTC
Linked fix does not fix this issue.

Comment 12 Peter Hutterer 2015-06-03 00:22:47 UTC
libinput-0.16.0-3.fc22 should fix it. it's still not configurable but the timeout is now short enough that it shouldn't matter.

Comment 13 Fedora Update System 2015-06-04 01:44:42 UTC
libinput-0.17.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libinput-0.17.0-1.fc22

Comment 14 Peter Hutterer 2015-06-04 04:41:21 UTC
*** Bug 1227990 has been marked as a duplicate of this bug. ***

Comment 15 Peter Hutterer 2015-06-04 11:29:10 UTC
*** Bug 1226529 has been marked as a duplicate of this bug. ***

Comment 16 Yaroslav 2015-06-05 12:17:55 UTC
The timeout is still pretty noticeable - around a second.

Comment 17 Fedora Update System 2015-06-06 00:12:01 UTC
Package libinput-0.17.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libinput-0.17.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9555/libinput-0.17.0-1.fc22
then log in and leave karma (feedback).

Comment 18 Yaroslav 2015-06-06 01:06:03 UTC
I used exactly this package to test. Unfortunately the timeout is still noticeable. That's very strange option to have this timeout at the first place...

Comment 19 Fedora Update System 2015-06-07 16:03:42 UTC
libinput-0.17.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Yaroslav 2015-06-08 17:50:14 UTC
The timeout is still noticeable with libinput-0.17.0-1.fc22

Comment 21 Cheer Chunhao 2015-06-08 17:54:18 UTC
The issue is better now, but still not released *immediately*.

Comment 22 Peter Hutterer 2015-06-08 21:51:50 UTC
Yaroslav: the timeout is still there and will always be noticeable (especially when you know what to look for). It's down to 300ms now though which should be significantly less invasive.

As for why it is there:
http://wayland.freedesktop.org/libinput/doc/latest/tapping.html
picture d), to be able to lift and continue with the tap.


If you want to release the drag immediately you can simply tap one more time (picture f)

Comment 23 Yaroslav 2015-06-09 02:36:27 UTC
Thanks for the explanation. Will wait for this option to be configurable (if it is planned at all).

Thanks.


Note You need to log in before you can comment on or make changes to this bug.