Bug 122622 - kernel crashed when copying large file to removable hard disk!!!
Summary: kernel crashed when copying large file to removable hard disk!!!
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-06 12:54 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-12-07 06:08:07 UTC


Attachments (Terms of Use)

Description Need Real Name 2004-05-06 12:54:51 UTC
Description of problem:

I'm trying to copying an ISO file from root partition (/dev/hda3) to
my removable hard disk. My removable hard disk is 30GB TOSHIBA 2.5
inch hard disk with an IEEE1394/USB 2.0 removable hard disk case. The
hard disk connected to the system through USB 2.0 interface. The
system assigned /dev/sda with it. I mounted /dev/sda3, which is a ext3
partition I've just created. I typed the following command:

mke2fs -j /dev/sda3
tune2fs -c 60 -i 180 /dev/sda3
mount /dev/sda3 /mnt/tmp
cp /tmp/20040506.iso /mnt/tmp

The copying operation starts. But after a minute, a few lines of
kernel message printed out. The system dies... I cannot copy the
message exactly because the system died. The main idea is that, error
in kernel 2.6.5-smp, the swap is failed, and some register values
printed out also. The ISO file is produced by mkisofs, and about
4381MB in size. I'm planning to burn it on a DVD-R.

Also, my motherboard is INTEL D865PERL, /dev/hda and /dev/hdb are IDE
hard disks, hda is 120GB and hdb is 80GB. The system has 512MB DDR RAM.

I tried the operation twice, the same error occured, so I think it's
not a random error. I also tried the same operation within Red Hat
Linux 9.0.93 CDROM rescue mode, the copying operation successed.

Comment 1 Pete Zaitcev 2004-08-20 00:00:39 UTC
Modified in linux-2.4.22-1.2197.
Please confirm and close.


Comment 2 Dave Jones 2004-12-07 06:08:07 UTC
fc1 - eol


Note You need to log in before you can comment on or make changes to this bug.