Bug 122626 - RFE : Log window should focus on tail instead of head
RFE : Log window should focus on tail instead of head
Status: CLOSED DUPLICATE of bug 122451
Product: Fedora
Classification: Fedora
Component: system-logviewer (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2004-05-06 09:31 EDT by Didier
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Didier 2004-05-06 09:31:55 EDT
Description of problem:

In log files, new log events are appended at the tail of the file
instead of the head. By defaulting the view window to the head of the
logs, the user needs to repeatedly scroll to the bottom of the window
after every refresh.

From a usability POV, this renders the logviewer useless for constant
monitoring purposes.

Version-Release number of selected component (if applicable):


Additional info:

It would be preferrable if either :
- the user could indicate a maximum of lines to be displayed (cfr.
'tail -n') ;
- the view window would remember the scroll bar position (e.g. at the
bottom) ;
- the user would have the option to reversely display the log contents
(that is, bottom-to-top instead of top-to-bottom).
Comment 1 Didier 2004-05-06 16:46:24 EDT
Looks like this request covers at least partially bug #122451.

Comment 2 Chris Lumens 2004-11-19 13:37:07 EST

*** This bug has been marked as a duplicate of 122451 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.