Bug 122629 - screensaver causes complete lockup
screensaver causes complete lockup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 10:33 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 15:05:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-05-06 10:33:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Ignore if this is the same as reported bug #107270......

Certain screensavers causes a complete lockup requiring a reset to
reboot(keyboard & mouse become nonfunctional) .  No error messages get
logged after lockup. I traced this to the random screensaver setting
and it appears certain screensavers cause this. Under the "illusions
of depth" category, "boxed" causes a lockup everytime(several others
did as well but I didn't record them before discovering the problem).
 After I determined the cause I just set the screensaver to a single
setting( "julia" under the "fractals" category does not cause any
problem) and the unexplained random freezes stopped. I'm not sure if
it is even xscreensaver causing the problem as none of the bugs I
found sounded exactly like this.  This happens while using the KDE
desktop.

Version-Release number of selected component (if applicable):
xscreensaver-4.14-4

How reproducible:
Always

Steps to Reproduce:
1. right click---->"configure desktop" --> "screensaver" --->
"illusions of depth" --->"boxed" --> select "test".

    

Actual Results:  screen freezes up completely and there is no keyboard
or mouse action that can escape from the frozen screen. Computer must
be reset & rebooted.

Expected Results:  The screensaver should be viewable or at least
allow a method to get back to the desktop control.

Additional info:

VGA compatible controller: 
Intel Corp. 82865G Integrated Graphics Device (rev 02) 

D865GBFL motherboard 

monitor: Hitachi CM751

All graphic drivers were part of the fedora-core2-test3 installation.
Comment 1 Bill Nottingham 2004-05-21 14:10:09 EDT
This is probably a X or kernel bug. Just to clarify, are you using the
KDE screensavers?
Comment 2 Need Real Name 2004-05-21 15:05:24 EDT
I was using the KDE desktop so I guess they would be the KDE
screensavers.  However, as a followup, this appears fixed in the final
release.  I installed Fedora Core 2 and went through every screensaver
and none of them cause the lockup anymore.  Whatever changed between
the test3 release and core 2 final seems to have done the trick.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.