Bug 12267 - DGA 1 apps compiled against 4.0 segfault when run under 3.3.6
Summary: DGA 1 apps compiled against 4.0 segfault when run under 3.3.6
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-14 15:42 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-06 01:13:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-06-14 15:42:08 UTC
When I compile xmame with DGA 1 support on 6.9 beta1 (and thus against 4.0)
and after that run it under a 3.3.6 server it segfaults. I can't even get a
normal window stand alone an DGA screen.

Since xmame uses only DGA 1, I would expect it to still run under 3.3.6
even if compiled against 4.0 if this is not feasable atleast I would expect
to just get an DGA not available error and be able to run in a window.

Comment 1 Jeremy Katz 2000-06-15 00:54:44 UTC
If I remember correctly, there's a general bug in DGA1 support in XFree 4.0 (ie:
it doesn't work :)  I remember hearing this is fixed in the current XFree CVS
tree; if XF 4.0.1 isn't released soon, this and the multitude of other bugs in
the released XFree4 are going to cause quite a bit of trouble :(

About compiling against the XFree 4 version, very rarely can you compile a
program against a newer lib and have it work with the older version.  The other
way around is often desirable, although not always possible.

Comment 2 Hans de Goede 2000-06-15 05:30:43 UTC
This however isn't a regular program but an X-windows program and the X protocol
is supposed to not suffer from this, if I compile xmame without DGA support it
works fine under the 3.3 servers even if compiled against the 4.0 libs.

I can even run it against the 3.3 libs.

So to be clear I'm not trying to run xmame + DGA1 suppport against 3.3 libs,
just against a 3.3 server, so we're not talking about dynamic linkijg against
older libs here, just about talking to an older server. This should work fine
(see http 1.0 vs 1.1 etc etc)



Comment 3 Hans de Goede 2000-06-30 21:28:09 UTC
I jsut tried this again with XFree-devel-4.0-0.28 from the beta2/snapshot dir on
gribble and it still happens.


Comment 4 Bill Nottingham 2000-07-03 05:13:18 UTC
Still segafaults? Crud, that was supposed to be fixed.

Comment 5 Hans de Goede 2000-07-06 22:33:57 UTC
Yes, I also tried it with the X-snapshot which was releaes a few hours later in
the /pub/X dir (0.29 I believe).

I'll try again with beta3 this weekend and lett you know.

Comment 6 Hans de Goede 2000-07-07 21:06:14 UTC
Still there in beta3


Comment 7 Hans de Goede 2000-07-27 19:28:23 UTC
Still there on beta5, come on fix this one please, it is the last anoying bug
left in 6.9 the rest of 6.9 is great.


Comment 8 Bill Nottingham 2000-08-06 01:13:31 UTC
I can't reproduce this here; xmame, aktion, etc. compiled against 4.0 X libs
seem to run OK on a 3.3.x server.

Comment 9 Bill Nottingham 2000-08-06 22:42:49 UTC
This should be fixed in 4.0.1-0.43.

Comment 10 Hans de Goede 2000-08-07 06:09:01 UTC
Heuh, I thought you couldn't reproduce it, well anyway nice to have it fix, hint
for reproducing: most apps, atleast xmame need to be run with root rights to
even try to use dga and hence trip this bug.

But I guess you've figured that out in the end. Can I get this version anywhere
before RC1?



Comment 11 Hans de Goede 2000-08-11 19:46:31 UTC
Ah its fixed in RC1, you rule! This is great, really great!



Note You need to log in before you can comment on or make changes to this bug.