Bug 122674 - Test failed in octave source rpm
Test failed in octave source rpm
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: octave (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 15:58 EDT by dyulov
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 2.1.57-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 13:33:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dyulov 2004-05-06 15:58:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
MyIE2; .NET CLR 1.0.3705)

Description of problem:
In process build rpm from SRPMS I try run make check. When run 
testing process njt all tests passed. As a result package not build. 


Version-Release number of selected component (if applicable):
octave-2.1.50-6

How reproducible:
Always

Steps to Reproduce:
1.In spec file before options %install I add command make check
2.
3.
    

Actual Results:  Package not build and exit with error(2)

Additional info:

I try build packages gnu compiler gcc version 3.2.3 20030502 (Red Hat 
Linux 3.2.3-20).

Output:

> +make check
> make -f octMakefile check
> make -C test check
> Native configuration is i686-pc-linux-gnu
>            === octave tests ===
> Running ./octave.test/args/args.exp ...
> ........
> FAIL: octave.test/eval-catch/eval-catch-9.m
> FAIL: octave.test/eval-catch/eval-catch-10.m
> ........
> FAIL: octave.test/system/tilde_expand-1.m
> ........
> FAIL: octave.test/try/try-9.m
> FAIL: octave.test/try/try-10.m

> make[2]: *** [check] Error 1
> make[1]: *** [check] Error 2
> make: *** [check] Error 2
> error: Bad exit status
Comment 1 Lon Hohberger 2004-06-23 13:33:41 EDT
Fixed in rawhide.  It looks like the tests themselves were expecting
the wrong information (at least in some cases).

http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/octave-2.1.57-1.src.rpm

--- output ---
                === octave Summary ===

# of expected passes            1199
../src/octave version 2.1.57 (i686-pc-linux-gnu).
Copyright (C) 2004 John W. Eaton.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTIBILITY or
FITNESS FOR A PARTICULAR PURPOSE.

Additional information about Octave is available at http://www.octave.org.

Please contribute if you find this software useful.
For more information, visit http://www.octave.org/help-wanted.html

Report bugs to <bug-octave@bevo.che.wisc.edu> (but first, please read
http://www.octave.org/bugs.html to learn how to write a helpful report).

make[2]: Leaving directory `/sandbox/rpms/octave/octave-2.1.57/test'
make[1]: Leaving directory `/sandbox/rpms/octave/octave-2.1.57'
--- end output ---

Note You need to log in before you can comment on or make changes to this bug.