Bug 122687 - extremely poor performance with SATA drive on FC2
extremely poor performance with SATA drive on FC2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 18:56 EDT by Gene Czarcinski
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 08:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-05-06 18:56:59 EDT
Description of problem:
This is a little late in the development cycle but better late than
never ... I do hope this gets fixed sometime soon.

I have an ASUS SK8V mobo with an Opteron 140 (that is why the platform
is x86_64 although the problem may occur with other platforms).
  This mobo has an integrated controller supporting SATA drives:

00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA
RAID Controller (rev 80)

I have two Maxtor 120GB drives on the system .. an IDE drive on hda
and SATA drive on sda/hde (depending on kernel).

On FC1, the SATA drive comes up as /dev/sda and performs as expected
(more or less the same as the drive on /dev/hda).  On FC2, the drive
comes up as /dev/hde and performance sucks!
----------------------------------------------------------------------
hdparm output follows ... first is on FC1;
/dev/hda:
 
 Model=Maxtor 6Y120P0, FwRev=YAR41BW0, SerialNo=Y329G08E
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
 BuffType=DualPortCache, BuffSize=7936kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=240121728
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: (null):
 
 * signifies the current active mode
 
/dev/sda:
 Timing buffer-cache reads:   2400 MB in  2.00 seconds = 1200.00 MB/sec
 Timing buffered disk reads:  168 MB in  3.01 seconds =  55.81 MB/sec
----------------------------------------------------------------------

and now from FC2 (353 kernel);

/dev/hda:
 
 Model=Maxtor 6Y120P0, FwRev=YAR41BW0, SerialNo=Y329G08E
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
 BuffType=DualPortCache, BuffSize=7936kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=240121728
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: (null):
 
 * signifies the current active mode
 
 Timing buffer-cache reads:   2416 MB in  2.00 seconds = 1206.37 MB/sec
 Timing buffered disk reads:   14 MB in  3.47 seconds =   4.03 MB/sec

/dev/hde:
 
 Model=Maxtor 6Y120M0, FwRev=YAR51EW0, SerialNo=Y3LW358E
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=DualPortCache, BuffSize=7936kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=240121728
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 *mdma2
 UDMA modes: udma0 udma1 udma2
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: (null):
 
 * signifies the current active mode
 
 Timing buffer-cache reads:   2392 MB in  2.00 seconds = 1194.99 MB/sec
 Timing buffered disk reads:   10 MB in  3.18 seconds =   3.15 MB/sec
Comment 1 Gene Czarcinski 2004-05-06 19:02:36 EDT
Oops ... that second set did not show the problem ... everything is
slow.  Here is another set from FC2:

[root@hummer root]# hdparm -Tt /dev/hda
                                                                     
          
/dev/hda:
 Timing buffer-cache reads:   2364 MB in  2.00 seconds = 1181.59 MB/sec
 Timing buffered disk reads:  168 MB in  3.00 seconds =  55.93 MB/sec
[root@hummer root]# hdparm -Tt /dev/hde
                                                                     
          
/dev/hde:
 Timing buffer-cache reads:   2444 MB in  2.00 seconds = 1220.35 MB/sec
 Timing buffered disk reads:   12 MB in  3.40 seconds =   3.53 MB/sec
Comment 2 Gene Czarcinski 2004-05-10 16:08:24 EDT
Reported upstream as: http://bugzilla.kernel.org/show_bug.cgi?id=2670
Comment 3 Dave Jones 2005-01-11 00:07:36 EST
any improvement with todays 2.6.10 updates ?
Comment 4 Gene Czarcinski 2005-01-11 08:52:16 EST
I no longer run FC2 and have not had any problems with FC3.  Since FC2
and FC3 use basically the same kernel these days, I assume that it
works under FC2 as well.

Therefore, I am closing this report.

Note You need to log in before you can comment on or make changes to this bug.