Bug 1226956 - eclipse-jgit cause compilation errors when Scala-IDE plugin is installed
Summary: eclipse-jgit cause compilation errors when Scala-IDE plugin is installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-jgit
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-01 14:11 UTC by Robert Marcano
Modified: 2015-10-27 14:39 UTC (History)
7 users (show)

Fixed In Version: eclipse-jgit-4.1.0-4.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-27 09:54:55 UTC


Attachments (Terms of Use)
Eclipse log file (4.20 KB, text/plain)
2015-06-01 14:11 UTC, Robert Marcano
no flags Details

Description Robert Marcano 2015-06-01 14:11:05 UTC
Created attachment 1033363 [details]
Eclipse log file

Description of problem:

When Scala-IDE is installed all Scala projects show compilation errors, The attached log shows a NullPointerException when calling:

javax.xml.bind.DatatypeConverter.printBase64Binary(DatatypeConverter.java:435)

trying to debug the problem, I checked the source of printBase64Binary and noticed that the lines for that method aren't near 435 on the OpenJDK sources. This made me thing another implementation is packaged and loaded by one of the Eclipse classloaders. I found eclipse-jgit containing javax.xml.bind_2.0.0.v20080604-1500.jar and that one is the one being used. After removing that jar fromthe dropin directory, Scala-IDE was able to compile projects without errors.


Version-Release number of selected component (if applicable):

eclipse-jgit-3.7.0-2.fc22.noarch

Steps to Reproduce:
1. Install Scala-IDE from http://scala-ide.org/
2. Start Eclipse and create a new Scala project
3. Add a new Scala class to the project like:

Test.scala------

case object Test

end Test.scala------


Actual results:

Compilation errors on the project, Eclipse log file with the exception (see attached log)


Expected results:

Compilation should be successful


Additional info:

A lot of time has passed since I packaged Eclipse plugins for Fedora, so things changed a lot. I don't see manual replacement of jars with links to dependent jars. I didn't find where the javax.xml.bind_2.0.0.v20080604-1500.jar is pulled.

OpenJDK 8 already include that implementation, to use that specific implementation look like is not needed, or at least to be isolated to only that plugin and not make it public to other plugins.

Comment 1 Mat Booth 2015-10-27 09:54:55 UTC
eclipse-jgit in Fedora 22 and newer has been upgraded to version 4.1.0 and no longer contains a symlink to the "javax.xml.bind" bundle

This hopefully fixes your problem -- please re-open if this is not the case.

Comment 2 Robert Marcano 2015-10-27 14:39:34 UTC
Thanks. solved.

There is still /usr/share/eclipse/dropins/egit-egit/eclipse/plugins/javax.xml.bind_2.0.0.v20080604-1500.jar on eclipse-egit but it doesn't affect Scala IDE plugin.

Tested 

1) dnf reinstalling eclipse-egit (restoring the other removed file) and updating eclipse-jgit. 
2) eclipse -clean
3) Project -> Clean All projects,

No compilation errors because of DatatypeConverter.printBase64Binary()


Note You need to log in before you can comment on or make changes to this bug.