Bug 122699 - a2ps "too many includes" error in sheets.map
Summary: a2ps "too many includes" error in sheets.map
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: a2ps
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-07 02:58 UTC by Wolfgang Mayer
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-12-07 14:33:39 UTC


Attachments (Terms of Use)
Patch for sheets-map.l (1.79 KB, patch)
2004-05-07 03:05 UTC, Wolfgang Mayer
no flags Details | Diff

Description Wolfgang Mayer 2004-05-07 02:58:46 UTC
Description of problem:

When overriding the default sheets.map in ~/.a2ps/sheets.map and
including /usr/share/a2ps/sheets/sheets.map, a2ps aborts with error
"too many includes".

Version-Release number of selected component (if applicable):
Fedora Core release 1 (Yarrow)

How reproducible:
Put 

include(/usr/share/a2ps/sheets/sheets.map)

in ~/.a2ps/sheets.map

Steps to Reproduce:
1. mkdir ~/.a2ps
2. echo 'include(/usr/share/a2ps/sheets/sheets.map)' >~/.a2ps/sheets.map
3.a2ps -o ~/hosts.ps /etc/hosts
  
Actual results:
a2ps: too many includes

Expected results:
PostScript file ~/hosts.ps created.


Additional info:

Comment 1 Wolfgang Mayer 2004-05-07 03:05:22 UTC
Created attachment 100061 [details]
Patch for sheets-map.l

I found this patch at
http://mail.gnu.org/archive/html/bug-a2ps/2002-01/msg00005.html
but it seems it is not integrated in the latest version available from
http://www.infres.enst.fr/~demaille/a2ps/ and it is not listed as known bug,
either. 

I didn't test this patch too carefully but it works for me.

Comment 2 Wolfgang Mayer 2004-05-07 03:09:18 UTC
Oops. The filename in the first line of the patch is incorrect. Remove
the '.orig'. Apologies.

Comment 3 Tim Waugh 2004-09-07 15:05:34 UTC
Fixed in CVS.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.