Bug 122709 - Yum segfaults while opening Pubkeys
Summary: Yum segfaults while opening Pubkeys
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: 2
Hardware: athlon Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-07 11:00 UTC by Jules Colding
Modified: 2014-01-21 22:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 02:40:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output of yum segfault (221.99 KB, application/octet-stream)
2004-05-07 11:20 UTC, Jules Colding
no flags Details
Pubkeys db (12.00 KB, application/octet-stream)
2004-05-07 20:03 UTC, Jules Colding
no flags Details

Description Jules Colding 2004-05-07 11:00:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040404 Firefox/0.8

Description of problem:
I was trying to do a "yum -y update". Yum segfaulted. Strace output
will be attached.



Version-Release number of selected component (if applicable):
yum-2.0.5-1

How reproducible:
Always

Steps to Reproduce:
1. yum update
2. SEGFAULT
3.
    

Actual Results:  yum segfaulted

Expected Results:  It should not segfault

Additional info:

I think that we might be dealing with an rpm bug even though yum is
the used component.

Comment 1 Jules Colding 2004-05-07 11:20:18 UTC
Created attachment 100071 [details]
strace output of yum segfault

The attachment is from "strace yum -y update".

Comment 2 Seth Vidal 2004-05-07 19:26:27 UTC
looks like your pubkeys db is borked some how.

switching to rpm from yum.


Comment 3 Jules Colding 2004-05-07 20:03:57 UTC
Created attachment 100094 [details]
Pubkeys db

Pupkeys db attached

Comment 4 Jeff Johnson 2004-05-07 21:10:02 UTC
Try
   rpm --rebuilddb -vv
That will fix any/all problems with the Pubkeys index.

Comment 5 Jules Colding 2004-05-08 13:09:48 UTC
Problem fixed. Thanks!


Note You need to log in before you can comment on or make changes to this bug.