Bug 12276 - Unresolved Dependency loop
Unresolved Dependency loop
Status: CLOSED DUPLICATE of bug 11987
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-14 12:46 EDT by James Manning
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-15 11:31:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2000-06-14 12:46:51 EDT
GUI install upgrade of RH 6.2 box.  The box is "unusual" in that it was
just through a failed upgrade (didn't actually start writing to disk as far
as I can tell, it never got past the part of not having enough space), and
it doesn't have enough space for the upgrade (it has about 143M free when
the last pass of the installer said 248M was needed).

The "first" screen of the Unresolved Dependencies lists:

Package         Requirement
isdn-config     initscripts
isdn4k-utils    no suggestion
kudzu           modutils

clicking "next" to accept the default of "Install packages to satisfy
dependencies" first scrolls a list of conflicts on vc3.  The beginning of
the list includes "initscripts-5.15-1 conflicts with to-be-installed
package timeconfig, removing from set" and " ... removed".  Others include
(not fully written out to save time, in-place package first,
to-be-installed second), in order:

setup-2.0.5-1 conflicts with initscripts
setup-2.1.8-1 conflicts with initscripts
setup-2.1.8-1 conflicts with initscripts
setup-2.0.5-1 conflicts with initscripts
setup-2.1.8-1 conflicts with initscripts
setup-2.1.8-1 conflicts with initscripts
sndconfig-0.47-1 conflicts with modutils
gnome-linuxconf-0.32-1 conflicts with linuxconf
pythonlib-1.25-1 conflicts with modutils
db2-2.4.14-0.1 conflicts with glibc
netcfg-2.27-1 conflicts with modutils
db1-1.85-0.3 conflicts with glibc
db1-devel-1.85-0.3 conflicts with glibc-devel
mkbootdisk-1.2.7-1 conflicts with modutils
db2-devel2.4.14-0.1 conflicts with glibc-devel
usermode-1.23-3 conflicts with SysVinit
setup-2.2.4-1 conflicts with initscripts
gnome-print-0.20-2 conflicts with gnumeric

The second action is that it gets to another "Unresolved dependencies" list
that is MUCH longer.   All of the entries (cpp, samba-common, nscd,
wu-ftpd, vim-enhanced being the first 5) have the requirement of glibc,
except for isdn4k-utils (one of the 3 from the previous screen) is still in
the list with "no suggestion", but the other 2 from the previous list
(isdn-config and kudzu) are gone.

Taking the default of "Install packages to satisfy dependencies" again
results in a similar, but slightly smaller, list of conflicts on vc3:

sndconfig-0.47-1 conflicts with modutils
gnome-linuxconf-0.32-1 conflicts with linuxconf
pythonlib-1.25-1 conflicts with modutils
db2-2.4.14-0.1 conflicts with glibc
netcfg-2.27-1 conflicts with modutils
db1-1.85-0.3 conflicts with glibc
db1-devel-1.85-0.3 conflicts with glibc-devel
mkbootdisk-1.2.7-1 conflicts with modutils
db2-devel2.4.14-0.1 conflicts with glibc-devel
usermode-1.23-3 conflicts with SysVinit
setup-2.2.4-1 conflicts with initscripts
gnome-print-0.20-2 conflicts with gnumeric

Note that this is the same list from before, just missing the initial
"initscripts" and 6 "setup" entries.

Now I'm back at the initial "Unresolved Dependencies" screen with
isdn-config, isdn4k-utils, and kudzu. (I've gone through the cycle 4 times
just to make sure it's really a cycle).  This time I select "Ignore package
dependencies" and it goes through to the "About to upgrade" screen fine.
Comment 1 Brock Organ 2000-06-17 23:57:16 EDT
thanks for the report!

*** This bug has been marked as a duplicate of 11987 ***

Note You need to log in before you can comment on or make changes to this bug.