Bug 122763 - Install fails with AIC7899W SCSI controller
Install fails with AIC7899W SCSI controller
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 14:44 EDT by Lawrence MacIntyre
Modified: 2015-01-04 17:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:28:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of lspci -vv -n using 2.4 kernel (8.09 KB, text/plain)
2004-05-07 14:47 EDT, Lawrence MacIntyre
no flags Details

  None (edit)
Description Lawrence MacIntyre 2004-05-07 14:44:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Dual XEON on SuperMicro PRDL6 motherboard.  Two SCSI disks.  The
installer fails to find any disks.  Fedora Core 1 and RedHat 9 are
working on the machine, but with the 2.4 kernel.  I have also tried to
install the generic kernel on the FC1 partition, but the driver has
the same problem.  I contacted the developer, got the latest driver,
but it has the same problem.  The developer suggested this:

> Then I don't know why it is not attaching. I would suggest
sprinkling > printks in the routine ahc_linux_pci_dev_probe() in the file
> drivers/scsi/aic7xxx/aic7xxx_osm_pci.c to try and narrow down the
> failure.

However, this routine is never reached, and I got no further input
from the developer.

Version-Release number of selected component (if applicable):
2.6.5-1.327

How reproducible:
Always

Steps to Reproduce:
1. Attempt to install FC2t3 on machine
2. 
3.
    

Actual Results:  installer can't find any disk drives

Expected Results:  Install should complete normally

Additional info:

When booting the 2.6.2 kernel with the FC1 install, this message appears:

loading aic7xxx.ko module
insmod: error inserting /lib/aic7xxx.ko: -1 No such device
Comment 1 Lawrence MacIntyre 2004-05-07 14:47:26 EDT
Created attachment 100092 [details]
output of lspci -vv -n using 2.4 kernel
Comment 2 Colin Charles 2004-08-29 19:54:20 EDT
Arjan,

aic7899 is still not in the Rawhide kernel (but apparently has been
with upstream kernel.org kernels since 2.6.6), and users can't get the
SCSI controller recognised (even though aix7xxx is included, but can't
be used)

This on an i386 machine, too
Comment 3 Arjan van de Ven 2004-08-30 03:38:54 EDT
eh the rawhide kernel is based on 2.6.9-rc1; anything "since 2.6.6"
sure is included 
Comment 4 Colin Charles 2004-09-03 20:21:45 EDT
Apologies, wrongly informed. This is the i2o stuff, which I think
*just* got merged in... Will tell user, thanks arjan
Comment 5 Jay Brinkmeyer 2004-10-29 16:06:44 EDT
Has this issue been fixed since this thread was posted? I'm trying to 
install FedoreCore2 on an Intel SE7500 machine that also requires a 
working AIC 7899 driver. So far, no luck. Anyone know of other RH 
distributions that can recognize the 7899?

Thanks,
JAy 
Comment 6 Dave Jones 2004-12-08 01:35:37 EST
any improvement with the latest update ?
Comment 7 Jay Brinkmeyer 2004-12-08 11:03:29 EST
All was well with Fedora Core 2 (no extra drivers needed) after I
added "acpi=off" to the linux startup line. Looks like there's some
sort of  interrupt compatiblity problem...
Comment 8 Dave Jones 2005-04-16 00:28:06 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.