Bug 122764 - Nautilius does not release fam on removable media
Nautilius does not release fam on removable media
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 122765 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 15:06 EDT by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 08:02:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-05-07 15:06:33 EDT
From Bugzilla Helper:
User-Agent: Opera/7.23 (X11; Linux i686; U)  [en]

Description of problem:
As in Fedora Core 1, when opening a file from a removable media such 
as a diskette, cd-rom, or mass-storage device, it becomes impossible 
to unmount the media again without killing off fam or doing a 
login/logout.

It seems like nautilius never tells fam to back off from the media 
when trying to unmount, as lsof shows that fam is the only prosess in 
the directory.

Getting the error message "device buisy"

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Mount a removable media in gnome
2.open it in nautilius, and open some files in f.ex. openoffice
3.Close down all programs that where holding it open (including 
nautlius)
4. Try to unmount
    

Actual Results:  Error message

Expected Results:  Unmounts the device

Additional info:

A workaround seems to be to copy files to the disk, open them there, 
and then back into the media...

The bug was there in FC1 as well.
Comment 1 Alan Cox 2004-06-14 18:22:10 EDT
*** Bug 122765 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Larsson 2004-10-05 08:02:25 EDT
I think this has been fixed with gamin in fc3. Please file a new bug
with the exact problem if you can reproduce something like this in
fc3test3 or later.
Comment 3 Kyrre Ness Sjøbæk 2004-10-05 10:08:01 EDT
This was fixed as one of the first updates that came with fc2. But,
yeah, it was annoying enough to make me switch to KDE in fc1...

Note You need to log in before you can comment on or make changes to this bug.