Bug 122765 - Nautilius does not release fam on removable media
Summary: Nautilius does not release fam on removable media
Status: CLOSED DUPLICATE of bug 122764
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-07 19:11 UTC by Kyrre Ness Sjøbæk
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kyrre Ness Sjøbæk 2004-05-07 19:11:22 UTC
From Bugzilla Helper:
User-Agent: Opera/7.23 (X11; Linux i686; U)  [en]

Description of problem:
As in Fedora Core 1, when opening a file from a removable media such 
as a diskette, cd-rom, or mass-storage device, it becomes impossible 
to unmount the media again without killing off fam or doing a 
login/logout.

It seems like nautilius never tells fam to back off from the media 
when trying to unmount, as lsof shows that fam is the only prosess in 
the directory.

Getting the error message "device buisy"

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Mount a removable media in gnome
2.open it in nautilius, and open some files in f.ex. openoffice
3.Close down all programs that where holding it open (including 
nautlius)
4. Try to unmount
    

Actual Results:  Error message

Expected Results:  Unmounts the device

Additional info:

A workaround seems to be to copy files to the disk, open them there, 
and then back into the media...

The bug was there in FC1 as well.

Comment 1 Alan Cox 2004-06-14 22:22:08 UTC

*** This bug has been marked as a duplicate of 122764 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:03:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.