Bug 122779 - vsftpd 1.2.0 has nasty bug
vsftpd 1.2.0 has nasty bug
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vsftpd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
: 123719 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 16:32 EDT by Jack Neely
Modified: 2014-03-16 22:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 14:26:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Neely 2004-05-07 16:32:47 EDT
Description of problem:
vsftp 1.2.0 suffers from a pretty nasty bug under high load with
listen=yes.  Eventually, the FTP process will stop responding to any
requests, and will be generally broken.

Please errata with 1.2.2.

Packages: ftp://ftp.linux.ncsu.edu/pub/contrib/jjneely/

From the 1.2.2 ChangeLog:

"Fix nasty issue resulting in listener instability under extreme load
(root cause was re-entering malloc/free)."

Version-Release number of selected component (if applicable):
vsftpd-1.2.0-4

How reproducible:
Needs high disconnect/connect load.  This appeared on
ftp.linux.ncsu.edu which is NCSU's Red Hat Linux/Fedora mirror.
Comment 1 Bill Nottingham 2004-05-21 14:26:05 EDT
This is already fixed in U2.
Comment 2 Bill Nottingham 2004-05-25 12:11:52 EDT
*** Bug 123719 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.