Bug 122822 - random system hangs
random system hangs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-08 13:53 EDT by Mark Rush
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 11:52:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Rush 2004-05-08 13:53:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506

Description of problem:
System randomly hangs at desktop, losing all input capability, does
not respond to ping.  Happens in kernel-smp 349-356, so far hasn't
happened in 327.  Uptime is normally less than 20 minutes on 356
before hang occurs. System log immediately prior shows something like
"nmbd[2096]:   register_name: Failed to send packet trying to register
name ^A^B__MSBROWSE__^B<01>" or "nmbd[2071]:   Packet send failed to
192.168.0.255(138) ERRNO=Invalid argument", though not sure if this is
always the case.  Happens whether I use reiserfs or ext3.  I don't
know if it happens when using kde.  I have Real Player 8 running most
of the time, with the rv9 codecs.

This system also experienced bug 109497 in FC1.  System was stable
using non-smp kernels.  Haven't tried non-smp 2.6.x kernel.



Version-Release number of selected component (if applicable):
kernel-smp 349-356

How reproducible:
Always

Steps to Reproduce:
1.Boot to desktop.
2.Do normal activity (surf net, chat with gaim, etc.) and wait usually
less than an hour.
3.
    

Actual Results:  System hangs.

Expected Results:  Normal operation.

Additional info:

P4 3.0 w/HT, Asus P4C800-E dlx mbd (i875P, ICH5R) w/most recent bios,
2G DDR400, eVga geforce fx 5900 128, 40G WD ATA, 80G seagate SATA,
r8139, onboard 82801EB/ER AC '97 audio, onboard CH5 e1000, toshiba
dvd, lg cdrw.
Comment 1 Mark Rush 2004-05-08 14:30:45 EDT
Also, at boot in smp kernels 349-356 am getting "ACPI: S3 and PAE do
not like each other for now, S3 disabled."
Comment 2 Dave Jones 2004-05-08 20:18:08 EDT
What modules do you have loaded ?
Comment 3 Mark Rush 2004-05-09 12:10:28 EDT
Results of lsmod:
snd_mixer_oss          17792  2
snd_intel8x0           30888  3
snd_ac97_codec         54916  1 snd_intel8x0
snd_pcm                76420  1 snd_intel8x0
snd_timer              22404  1 snd_pcm
snd_page_alloc         12036  2 snd_intel8x0,snd_pcm
gameport                7424  1 snd_intel8x0
snd_mpu401_uart         9088  1 snd_intel8x0
snd_rawmidi            21792  1 snd_mpu401_uart
snd_seq_device         10120  1 snd_rawmidi
snd                    43876  10
snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10336  3 snd
parport_pc             23616  1
lp                     12300  0
parport                34632  2 parport_pc,lp
autofs4                15488  0
sunrpc                110280  1
e1000                  73356  0
8139too                22656  0
mii                     7552  1 8139too
ipt_REJECT              8704  0
ipt_state               5504  0
ip_conntrack           30348  1 ipt_state
iptable_filter          6016  0
ip_tables              18048  3 ipt_REJECT,ipt_state,iptable_filter
floppy                 52336  0
sg                     32288  0
microcode              10400  0
ipv6                  214624  10
dm_mod                 37536  0
joydev                 10944  0
uhci_hcd               28188  0
ehci_hcd               26760  0
button                  8472  0
battery                10892  0
asus_acpi              12440  0
ac                      7308  0
reiserfs              195540  3
ata_piix                9348  0
libata                 33536  1 ata_piix,[permanent]
sd_mod                 20352  0
scsi_mod               97224  3 sg,libata,sd_mod

Btw systems seems stable using non-smp kernels.
Comment 4 Mark Rush 2004-05-09 13:49:34 EDT
Still happening with kernel-smp-2.6.5-1.358.  Last entry in system log
before hang is "May  9 12:40:15 fedoracore nmbd[2068]:   *****"  I
doubt that samba is having anything to do with it though because hang
has occurred while smbd and nmbd were not running.
Comment 5 Mark Rush 2004-05-12 12:29:39 EDT
This is probably just bug 109497 continued: system is stable (except
for  bug 122316) using smp kernels with USB disabled in BIOS and using
the nousb kernel option in grub.
Comment 6 Mark Rush 2004-05-23 11:30:59 EDT
Found out I'm having major hardware problems (either mbd, cpu, or
memory), so ignore my comments.

Note You need to log in before you can comment on or make changes to this bug.