Bug 122846 - system-config-network behaves incorrectly when PEERDNS is not in config file
system-config-network behaves incorrectly when PEERDNS is not in config file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 124634 (view as bug list)
Depends On:
Blocks: 86560
  Show dependency treegraph
 
Reported: 2004-05-09 00:08 EDT by Phil Anderson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 19:18:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phil Anderson 2004-05-09 00:08:08 EDT
If a config file for a device doesn't contain a PEERDNS entry, then
the ifup script behaves as if PEERDNS=yes, but system-config network
behaves as if PEERDNS=no.  i.e. the 'Automatically Obtain DNS
Information' checkbox is unchecked.

If PEERDNS isn't set, the behavior of system-config-network and the
ifup scripts should be the same.

If PEERDNS is set, then system-config-network always displays the
correct setting.
Comment 1 Ricky Ng-Adam 2004-05-24 15:05:00 EDT
Phil Anderson replied to one of my email linking this bug to the
following text.  I'm posting it here just to make sure...

"My next step was to launch the browser.  As expected, my connection
didn't work - I had noticed that the install program had decided to
choose eth0 (a NIC that has no cable connected to it) instead of the
more suitable eth1 (connected to my W2K bunch that uses ICS to share
the Internet connection) as active per default.

I went in Network to switch both and tell it to use DHCP eth1 instead
of eth0.  I restarted and tried again but no luck - it couldn't
resolve hostname.  After messing around, I finally found that I needed
to activate the checkbox "Automatically obtain DNS Information from
provider". I not sure why this wasn't done automatically, but at least
now I was able to get on the net."
Comment 2 Harald Hoyer 2004-06-04 09:10:43 EDT
*** Bug 124634 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.