Bug 122847 - + metachar not ed compatible
Summary: + metachar not ed compatible
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: less   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-09 05:44 UTC by Mikel Ward
Modified: 2013-07-02 23:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-19 10:48:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikel Ward 2004-05-09 05:44:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040506 Epiphany/1.2.4

Description of problem:
Less(1) claims to be ed(1) compatible in the man page, as one would
expect from most Unix utilites except for Awk, Egrep, Perl, etc., but
in Less + is used as a metacharacter unescaped, so matching a literal
+ requires the pattern be \+.  This is the opposite of ed, and is
rather confusing.

Version-Release number of selected component (if applicable):
less-382-3

How reproducible:
Always

Steps to Reproduce:
1. man bash
2. /:+

    

Actual Results:  Taken to the first instance of the literal ":" in the
bash(1) manual page (the "OPTIONS" section).

Expected Results:  Taken to the first instance of the literal ":+" in
the bash(1) manual page (the "Use Alternate Value" section).

Additional info:

A quick look at the Less home page suggests it plugs into many
different regex libraries.

It looks like the version of Less distributed with Red Hat/Fedora uses
enhanced regular expressions rather than basic regular expressions. 
If  this is the case, the manual page must be updated to reflect this.

Comment 1 Jindrich Novy 2005-10-19 10:48:37 UTC
This is now fixed by the less-392.

man page now states that:
The pattern is a regular expression, as recognized by the regular expression
library supplied by your system.


Note You need to log in before you can comment on or make changes to this bug.