Bug 122855 - fix packages for perl 5.8.3 and perl-suidperl 5.8.3 need perl-NDBM_File <= 1:1.75-34.99.6
fix packages for perl 5.8.3 and perl-suidperl 5.8.3 need perl-NDBM_File <= 1:...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-09 07:35 EDT by Nick Simicich
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 22:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Simicich 2004-05-09 07:35:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I currently have a Fedora core 1 system, which was installed via
upgrade from CD.  I have been keeping maintenance up to date, and an
up2date -u tells me that everything is just peachy, but that is
because I have told it to ignore the package perl and perl-suidperl.

Up2date offers me two RPMs which I cannot install, perl and perl-suidperl:

Here is the command I run and the messages:

[root@quickdraw yum]# up2date perl perl-suidperl
 
Fetching package list for channel: fedora-core-1...
 
Fetching
http://download.fedora.redhat.com/pub/fedora/linux/core/1/i386/os//headers/header.info...
########################################
 
Fetching package list for channel: updates-released...
 
Fetching
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386//headers/header.info...
########################################
 
Fetching package list for channel: rsync-downloaded-RPMs...
########################################
 
Fetching Obsoletes list for channel: fedora-core-1...
 
Fetching Obsoletes list for channel: updates-released...
 
Fetching Obsoletes list for channel: rsync-downloaded-RPMs...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
perl                                    5.8.3          16            
     i386                                                            
                    
perl-suidperl                           5.8.3          16.1          
     i386                                                            
                    
 
 
Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:
 
Unresolvable chain of dependencies:
perl-5.8.3-16                            requires perl-NDBM_File <=
1:1.75-34.99.6

-=-=-=-=-
Trying with yum gives me the same sort of issue:

[root@quickdraw yum]# yum update perl perl-suidperl perl-NDBM_File
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
Server: Fedora Core 1 - i386 - Released Updates
Finding updated packages
Downloading needed headers
perl-NDBM_File is installed and the latest version.
Resolving dependencies
.conflict between perl and perl-NDBM_File
[root@quickdraw yum]#

-=-=-=-=-
Finally, what do I have installed now?

[root@quickdraw yum]# rpm -q perl perl-suidperl perl-NDBM_File
perl-5.8.1-92
perl-suidperl-5.8.1-92
perl-NDBM_File-1.75-34.99.6
[root@quickdraw yum]#


I have not tried up2date -u for a while - I see that there is a
similar problem with spamassassin, but I would like to work through
this problem first.  I can't figure out why there is an issue with my
system.

Asking on IRC makes me believe that this issue is one of what I have
installed. Those people who had managed to upgrade to the this level
of perl and suidperl did not have perl-NDBM_File installed.

Version-Release number of selected component (if applicable):
perl-5.8.3-16 perl-suidperl-5.8.3-16.1 

How reproducible:
Always

Steps to Reproduce:
1. up2date -u
2.
3.
    

Actual Results:  Unresolvable chain of dependencies:
perl-5.8.3-16                            requires perl-NDBM_File <=
1:1.75-34.99.6

Expected Results:  I expected the fixes to be installed.

Additional info:
Comment 1 Warren Togami 2005-09-23 11:33:31 EDT
I have no idea where you got this package, but according to Bug #77351 we have
never shipped NDBM_File since 2002 or maybe even earlier.

Note You need to log in before you can comment on or make changes to this bug.