Bug 122872 - KDE, with Selinux in enforcing, will not allow Kde apps. that require SU to run
KDE, with Selinux in enforcing, will not allow Kde apps. that require SU to run
Status: CLOSED DUPLICATE of bug 121309
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-09 14:58 EDT by jim tate
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jim tate 2004-05-09 14:58:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040316

Description of problem:
When setting SELINUX=enforcing it will prevent a kde application,that
requires SU to run.
Like KonquerorSU filemanager if you click on it, it will attempt to run
but the window that is supposed to popup to allow you type in SU
password, will not popup and after about 10sec. it will quit running.
This also happens if you try to run Terminal Program superuser mode.
If I reset SELINUX=permissive, and reboot computer, the the kde apps.
SU mode will popup window to allow you to type in SU password, and then
they will execute.
Only the KDE apps have this problem, SytemTools/Redhat Network,
Network Config all work fine and allow you to type in SU password and
then execute.
I have test3 installed on a P3/800 and AMD athlon/MP running smp and
this problem occurs on both boxes, identicle situation.

Version-Release number of selected component (if applicable):
kdebase-3.2.2-4  policy-1.11.3-3

How reproducible:
Always

Steps to Reproduce:
1Click on /System Tools/More System Tools/File Manager - Superuser Mode.
2Application will start to run , in KDE
3 And after about ten seconds it just stops running..
    

Actual Results:  Just pops back to KDE Desktop

Expected Results:  A window to popup to allow you to type in SU password,
But it doesn't.

Additional info:

This problem has always been there in Fedora2 after Selinux was
installed. And Set to SELINUX=enforcing.
Comment 1 Ben Levenson 2004-05-26 16:38:30 EDT
closing as dup of bug# 121309

*** This bug has been marked as a duplicate of 121309 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.