Bug 122913 - mdadm %postun script exits with a failure
mdadm %postun script exits with a failure
Status: CLOSED DUPLICATE of bug 112425
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mdadm (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-10 08:59 EDT by Bill Peck
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2004-05-10 08:59:49 EDT
Description of problem:
The %postun script of mdadm exits with a failure.  This happens if you
downgrade the package to a previous version.

Version-Release number of selected component (if applicable):
mdadm-1.5.0-3

How reproducible:
everytime I downgraded

Steps to Reproduce:
1. install mdadm-1.5.0-3
2. Downgrade to a previous version
3. 
  
Actual results:
[root@threeware RPMS]# rpm -Uvh --oldpackage mdadm-1.0.1-1.i386.rpm
warning: mdadm-1.0.1-1.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...               
########################################### [100%]
   1:mdadm                 
########################################### [100%]
error: %postun(mdadm-1.5.0-3) scriptlet failed, exit status 1


Expected results:
No errors

Additional info:
What I don't know is if this will show up on an upgrade when we
release a newer version of mdadm.
Comment 1 Doug Ledford 2004-05-12 13:27:13 EDT
No, it only happens when you downgrade to a version of mdadm that does
not include the mdmpd daemon.  For the most part, it's only cosmetic,
nothing bad is happening.  In any case, should be fixed as of 1.5.0-6
and later.

*** This bug has been marked as a duplicate of 112425 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.