Bug 122916 - RHEL3 U7: provide support for PowerNow! CPU frequency and voltage transitions for Athlon 64 systems, based on BIOS state tables.
RHEL3 U7: provide support for PowerNow! CPU frequency and voltage transition...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Kernel
: FutureFeature
Depends On:
Blocks: 170417 193183
  Show dependency treegraph
 
Reported: 2004-05-10 09:49 EDT by Susan Denham
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 14:57:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2.4 cpufreq driver for the AMD Athlon 64 CPU. It has been reviewed by the cpufreq maintainer and tested by AMD. Patch was taken against the stock 2.4.21 kernel from kernel.org. (18.00 KB, patch)
2004-05-10 10:43 EDT, Susan Denham
no flags Details | Diff

  None (edit)
Comment 1 Susan Denham 2004-05-10 09:49:08 EDT
Status: Patch developed 8/03 by AMD.  AMD has tested 
it and will test the integrated patch.  Patch forwarded
to Red Hat on 5/03/04 by Mark Langsdorf.

Hardware to Red Hat: Red Hat should have an AMD64 
laptop.
Comment 2 Susan Denham 2004-05-10 10:43:18 EDT
Created attachment 100126 [details]
2.4 cpufreq
driver for the AMD Athlon 64 CPU.  It has been 
reviewed by the cpufreq maintainer and tested by
AMD.


Patch was taken against the stock 2.4.21 kernel 
from kernel.org.


Patch was taken against the stock 2.4.21 kernel 
from kernel.org.
Comment 3 Robert Perkins 2004-05-11 16:13:38 EDT
Donald, can you please resolve this one, mr. desktop?
Comment 5 Susan Denham 2004-06-18 13:01:40 EDT
Mark Langsdorf can't provide code until July 1, which makes it too late for U3.
 Changing summary line to U4.
Comment 6 Susan Denham 2004-08-25 22:59:42 EDT
Ignore previous comment; AMD (Mark Langsdorf) provided patch on 5/3/04 and it's
included here as attachment.  We have everything we need.
Comment 7 Susan Denham 2004-08-26 10:47:46 EDT
Jim, can you please confirm that you have everything you need from AMD in order
to incorporate this support for U4?
Comment 8 Jim Paradis 2004-08-26 14:56:07 EDT
I have a bit of twiddling to do on it (hammer the driver into the particular
format used in RHEL3) but I have all the material I need to do so.
Comment 9 Jim Paradis 2004-08-30 19:32:09 EDT
I have a prototype driver that builds, but the one appropriate system I have
tried it on so far (Compaq R3000 Athlon64-based laptop) does not have the
required BIOS tables.  I'm working with AMD to be able to test this.
Comment 13 Marty Wesley 2005-05-26 02:45:35 EDT
PM ACK for U6
Comment 18 Brian Maly 2005-08-23 15:53:56 EDT
I looked into this issue to see where we currently stand...

It looks like we have powernow-k6 in RHEL3, but not powernow-k7 or powernow-k8.

The powernow driver needs updating in RHEL3 to something more current...
Comment 22 Tom Kincaid 2005-10-11 10:38:54 EDT
QE ACK. 

I will be looking for testing help from AMD and HP.

Comment 23 Brian Maly 2005-10-18 16:52:15 EDT
More info. Updating the powernow driver to 1.00.08 should do the trick. This may
also require some updates to the cpufreq driver as well. Updating cpufreq may
cause regression to Intel Speedstep (which also needs updating). I recommend
updating cpufreq, powernow, and speedstep drivers together.
Comment 25 Brian Maly 2005-10-21 14:12:41 EDT
just a quick note here. Adding powernow functionality will also require adding
the cpuspeed daemon package (userspace app) to RHEL3 so that the userspace
governor can be used.


Note You need to log in before you can comment on or make changes to this bug.