Bug 122927 - Gnome System Sounds do not play - other sounds ok
Gnome System Sounds do not play - other sounds ok
Product: Fedora
Classification: Fedora
Component: gnome-audio (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
Depends On:
  Show dependency treegraph
Reported: 2004-05-10 11:12 EDT by Gerry Tool
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-20 16:05:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2004-05-10 11:12:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506

Description of problem:
Gnome System sounds will not play even though the sound system works
for all other functions and the "Sounds for events" and "Enable sound
server startup" checkboxes are checked in Start Here > Preferences >

I can play music fine and I can play the test sound fine in the menu
System Settings > Sound card Detection > Play test sound.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Open the Start Here dialog by clicking the desktop icon
2.Oen the Preferences dialog by clicking the icon in the start-here
3.Open the Sound preferences dialog by clicking on the Sound icon.
4.Ensure that Enable sound server startup and Sound for events check
boxes are checked.
5.Select the Sound Events tab.
6.Scroll to a System events item such as Login which displays the name
of a sound file to play.
7.Click on Play to hear the sound.


Actual Results:  No sound plays

Expected Results:  The sound file should play.

Additional info:

On logout, a very short truncation of the Log Out file shutdown1.wav
plays.  No other sound events work at all.
Comment 1 Gerry Tool 2004-05-10 11:13:34 EDT
I forgot to mention that system sounds in KDE do work.
Comment 2 Boris Goldowsky 2004-05-13 09:00:32 EDT
I seem to be having the same problem - no system sounds, though sound
Comment 3 B.J. McClure 2004-05-13 19:01:20 EDT
Identical issue on two boxes.
Comment 4 Radu Cornea 2004-05-18 23:02:23 EDT
Same here.
Comment 5 Jack Spaar 2004-05-19 14:48:52 EDT
Likewise, on an upgrade to FC2final from FC1.  A few more details:

esd is running
$ esdplay <wavefile>  works fine.
$ playwave <wavefile> works fine.
$ xmms plays fine.
$ gnome-volume-control has two tabs, one for OSS and one for alsa
mixer.  Settings looks good except the alsa mixer tab has duplicates
for the cd player, mic, etc.
$ gnome-alsamixer doesn't have duplicates.

After the upgrade, alsa was not working at all because:
1) modprobe was still loading cmpci instead of snd-cmipci (CMedia driver)
2) permissions were not set properly on /dev/snd*

Running alsactl as root and then commenting out cmpci in modprobe.conf
solved problem 1.
Editting /etc/security/console.perms solved problem 2.
Comment 6 Guy Fraser 2004-05-19 17:34:32 EDT
Same here:
i810 + AD198x codec on a ASUS P4PE Mother board.
XMMS plays WAV files, KDE plays all files , Gnome plays no system 
Comment 7 David Evans 2004-05-19 20:20:39 EDT
I have the same problem - it happened on a FC2T3 install, and just
today I re-formatted and did a clean install of FC2 final.  I can play
MP3s, WAVs from Mozilla (for email notification) but can not play
System sounds, and do not get system bells.

Hardware is an IBM Thinkpad A31 Pentium 4 with integrated sound shows
up as Intel 82801CA-ICH3 in the Alsa Mixer tab of the Volume Control
panel.  There is also an "Analog Devices AD1881A,Silicon" for Audio
Mixer (OSS).  

I have set up the "Enable sound server startup" and turned the volume
up on all the channels I could find.  
Comment 8 Colin Walters 2004-05-19 21:28:23 EDT
Hi - basically I suck and broke sound events.  I'll be pushing an
errata for libgnome soon.

This should already be fixed in rawhide though.  Could people verify
that the latest rawhide package (libgnome-2.6.0-3) works?
Comment 9 Jack Spaar 2004-05-19 22:32:49 EDT
Installed libgnome-2.6.0-3 (dated May 15) and it works (mostly) for me. 

I don't hear a sound at login.  But other system events and ui events
work fine.  (I thought there used to be a sound for minimizing
windows, but there's no category for that in sound preferences.)
Comment 10 Gerry Tool 2004-05-19 23:52:09 EDT
libgnome-2.6.0-3 fixes the gnome system sounds on my system.  Now that
they work, I just realized there are a lot less sound events in the
list than there used to be.  Login doesn't actually play a sound, but
the file plays in the test mode in Preferences > Sounds.
Comment 11 Boris Goldowsky 2004-05-20 08:32:13 EDT
Fix works for me too.  Thanks, Colin!
Comment 12 Colin Walters 2004-05-20 16:05:03 EDT
I just released a FC2 update.
Comment 13 EVENO Gaël 2004-05-26 04:45:59 EDT
I get gnome 2.6.1 from sources.
I use libgnome and have got the problem again.
gnome-sound-properties --enable-sound from a terminal is ok, I can
hear sounds with the "play" button, same as games with the
"--enable-sound" option from a terminal, but not directly clicking on
the panel , etc...

Any idea?
Comment 14 Colin Walters 2004-05-26 08:07:59 EDT
Yes, the bug is in upstream 2.6.1 (introduced by me).  It is also
fixed in CVS, should work in 2.6.2.

Note You need to log in before you can comment on or make changes to this bug.