Bug 122948 - Evolution "Cannot access the Ximian Evolution Shell" x86_64 evolution-1.4.6-2
Evolution "Cannot access the Ximian Evolution Shell" x86_64 evolution-1.4.6-2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
http://bugzilla.ximian.com/show_bug.c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-10 13:43 EDT by taj
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 18:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description taj 2004-05-10 13:43:07 EDT
Description of problem:

After upgrading several packages in the devel tree, evolution failed
to start.

A dialog box "Cannot access the Ximian Evolution Shell" was displayed.

Trying to run evolution-wombat generated:

/usr/libexec/evolution/1.4/evolution-wombat
wombat-Message: Starting wombat
wombat-pas-Message: Error registering the PAS factory: not listed
wombat-Message: main(): could not initialize Wombat service "PAS";
terminating

Version-Release number of selected component (if applicable):


How reproducible:  Always if the account had previously run evolution.
 Never with new accounts.


Steps to Reproduce:
1.  start evolution
2.  watch it fail with the above messages
3.
  
Actual results:

evolution dies

Expected results:

evolution runs.

Additional info:

backing up to evolution-1.4.6-1 did not solve the problem - though it
worked in the past. 

Bug also filed by mistake at
http://bugzilla.ximian.com/show_bug.cgi?id=58269
Comment 1 taj 2004-05-10 13:44:30 EDT
work around was to remove files and directories from /tmp.  For
instance with user test:

/tmp/orbit-test
/tmp/orbit-test/linc-896-0-4fc289545365b
/tmp/orbit-test/bonobo-activation-register.lock
/tmp/orbit-test/linc-898-0-7470689e9613d
/tmp/orbit-test/bonobo-activation-server-ior
/tmp/orbit-test/linc-89a-0-21e34e13aa63b
/tmp/orbit-test/linc-89c-0-5599b67ce42d3
/tmp/gconfd-test
/tmp/gconfd-test/lock
/tmp/gconfd-test/lock/ior


No problems after that.
Comment 2 Dave Malcolm 2004-09-22 14:18:32 EDT
Has this problem recurred, or should I close this bug?
Comment 3 taj 2004-09-23 01:13:06 EDT
Hi Dave,

I've since then moved on to evolution 1.5.  The bug is not being
reproduced at this time.
Comment 4 Dave Malcolm 2004-09-23 18:00:02 EDT
Thanks - perhaps a stale lockfile?  Not much more that can be done
with this unless it recurs for someone.  Resolving as WONTFIX here and
upstream

Note You need to log in before you can comment on or make changes to this bug.