Bug 122995 - OpenOffice.org hangs when saving documents
OpenOffice.org hangs when saving documents
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-11 03:55 EDT by Michael Opdenacker
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 07:56:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Opdenacker 2004-05-11 03:55:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506

Description of problem:
Hello,

Here's a bug and a work-around.

I've make a fresh install of FC2T3, but I'm using a /home/
directory which was already used with FC1.

I noticed that I couldn't save the OpenOffice.org documents
that I edited: the application always hangs when I run the 
"Save" command. It consumes a lot of CPU then.

I also noticed that this doesn't happen with newly created
accounts, and that moving away my .sversionrc file and .rhopenoffice
directory fixes this issue.

As .rhopenoffice1.1 didn't exist in FC1, I guess this bug
comes from intermediate testing versions of OpenOffice.org,
and shouldn't happen to FC2 users who haven't tried the FC2 test
releases.

I just document this in case other testers face this issue too.

Don't hesitate to close this ticket.

Cheers,

Michael.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-4

How reproducible:
Always

Steps to Reproduce:
1. Open an OpenOffice.org document
2. Try to save the document

Additional info:
Comment 1 Dan Williams 2004-05-11 09:09:38 EDT
Michael,

Could you help me track the problem down a bit more?  When OOo hangs,
could you open a terminal and do:

1) pidof soffice.bin
2) gdb
3) attach <number returned by step 1>
4) t a a bt

And then attach that output here?  You could also attach the output of
 the command "strace -p `pidof soffice.bin`" (hit Ctrl-C to quit).

Thanks!
Dan
Comment 2 Michael Opdenacker 2004-05-11 11:03:32 EDT
Hi Dan,

Thank you for investigating this!
Here are the log files that you asked for
(start from the end... there's too much 
stuff at the beginning):

http://michaelo.free.fr/issues/openoffice_hangs_may11_2004/

Hoping this helps...

Cheers,

Michael.
Comment 3 Dan Williams 2004-05-11 11:30:48 EDT
Michael,

Could you try one more thing?  If you're using bash for your shell, try:

export LD_ASSUME_KERNEL=2.2.5
/usr/bin/oowriter
<try saving your doc, let it hang>
<the grab another gdb backtrace like I posted above>

NPTL may be screwing up the backtrace a bit...

Thanks.
Comment 4 Michael Opdenacker 2004-05-11 11:39:27 EDT
Hi Dan,

Here is the second dump backtrace you asked for:
http://michaelo.free.fr/issues/openoffice_hangs_may11_2004/gdb_output2.log.bz2

:-)

Michael.
Comment 5 Dan Williams 2004-09-25 16:59:05 EDT
hmm, your server seems to be down...  can you update the link?
Comment 6 Michael Opdenacker 2004-10-01 13:23:26 EDT
Oops, sorry about the broken site!
The new URL is:
http://opdenacker.org/issues/openoffice_hangs_may11_2004/
(Replace "michaelo.free.fr" by "opdenacker.org")

Thanks for everything!

:-)

Michael
Comment 7 Dan Williams 2004-11-03 15:14:19 EST
Is there any way you could test with teh latest OOo in FC2 (1.1.2-10.fc2).

Thanks!
Dan
Comment 8 Michael Opdenacker 2004-11-03 16:48:36 EST
Hi Dan,

This issue no longers happens to me with the latest FC2 version
(1.1.2-10.fc2).

I think you should close this old bug.

Thanks a lot for your help!

Cheers,

Michael.
Comment 9 Douglas Furlong 2004-11-04 08:07:49 EST
Hi Dan, I am having a similar problem here.

We have upgraded from 1.1.1, to 1.1.2, and on some documents, when
going to save a document the system appears to freeze.
I have not tried the work around of above.

I have run the requested commands you gave to Michael, I hope it is of
help.

Thread 5 (Thread -189379664 (LWP 3999)):
#0  0x002807a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x005d0188 in accept () from /lib/tls/libpthread.so.0
#2  0xf63283c2 in osl_acceptPipe () from
/usr/lib/ooo-1.1/program/libsal.so.3
#3  0xf654f28e in vos::OPipe::accept ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#4  0x0806f7bd in desktop::OfficeIPCThread::run ()
#5  0xf6548db2 in vos::_cpp_OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#6  0xf6548d97 in _OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#7  0xf631d3a7 in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#8  0x005ca98c in start_thread () from /lib/tls/libpthread.so.0
#9  0x0035416a in clone () from /lib/tls/libc.so.6

Thread 4 (Thread -202478672 (LWP 4000)):
#0  0x002807a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x005cd950 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
#2  0xf6319daf in osl_waitCondition ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#3  0xf65423fd in vos::OCondition::wait ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#4  0xf654c410 in vos::OTimerManager::run ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#5  0xf6548db2 in vos::_cpp_OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#6  0xf6548d97 in _OThread_WorkerFunction ()
   from /usr/lib/ooo-1.1/program/libvos3gcc3.so
#7  0xf631d3a7 in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#8  0x005ca98c in start_thread () from /lib/tls/libpthread.so.0
#9  0x0035416a in clone () from /lib/tls/libc.so.6

Thread 3 (Thread -252392528 (LWP 4003)):
#0  0x002807a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0034aa27 in poll () from /lib/tls/libc.so.6
#2  0xf0f69855 in ?? () from /usr/lib/ooo-1.1/program/libdtransX11645li.so
#3  0xf0f699c7 in ?? () from /usr/lib/ooo-1.1/program/libdtransX11645li.so
#4  0xf631d3a7 in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#5  0x005ca98c in start_thread () from /lib/tls/libpthread.so.0
#6  0x0035416a in clone () from /lib/tls/libc.so.6
Thread 2 (Thread -303301712 (LWP 4005)):
#0  0x002807a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0034aa27 in poll () from /lib/tls/libc.so.6
#2  0x004f4156 in g_main_loop_get_context () from
/usr/lib/libglib-2.0.so.0
#3  0x004f3590 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#4  0x004f3c53 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#5  0x00138cd2 in link_thread_io_context () from /usr/lib/libORBit-2.so.0
#6  0x0050d1bd in g_static_private_free () from /usr/lib/libglib-2.0.so.0
#7  0x005ca98c in start_thread () from /lib/tls/libpthread.so.0
#8  0x0035416a in clone () from /lib/tls/libc.so.6

Thread 1 (Thread -177752704 (LWP 3982)):
#0  0x002807a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x005cff7b in __read_nocancel () from /lib/tls/libpthread.so.0
#2  0xed4a838d in ?? () from /usr/lib/libfam.so.0
#3  0x00000028 in ?? ()
#4  0xfee63300 in ?? ()
#5  0x00000004 in ?? ()
#6  0x00000406 in ?? () from /usr/lib/libxml2.so.2
#7  0x00000406 in ?? () from /usr/lib/libxml2.so.2
#8  0x00000000 in ?? ()
#0  0x002807a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2

strace -p `pidof soffice.bin`
Process 3982 attached - interrupt to quit
read(40, 

It just sits there on for quite a while. I had to CTRL+C out of it.

I tried running OOCalc after exporting the kernel version, however
even though it opens, when I attempt to open a file it hangs.

Is this related to this bug or should I open up a new bug report?



Comment 10 Dan Williams 2004-11-11 14:44:49 EST
Is there _any_ way you could attach a document that freezes, or
privately email it to me?

Also, the backtrace posted in comment 9 isnt' going to help much (not
your fault) because the hang is in Thread 1, which doesn't have a
descriptive stacktrace.  The way to potentially get one is to install
the openoffice.org-debuginfo package, but that's 500MB download...

So if I can get a document, I can try to reproduce and fix it much
more easily...
Comment 11 Douglas Furlong 2004-11-12 08:17:11 EST
Hi Dan.

I have just installed the debuginfo version, I'm not sure if there is
any thing "special" that I need to do (the non debug version is still
installed). Please find below the details of those commands I ran
previously, with the debug version (I think).

---------------------------------------------------------------------
(gdb) t a a bt

Thread 5 (Thread -189482064 (LWP 8419)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00cde3b8 in accept () from /lib/tls/libpthread.so.0
#2  0xf631850a in osl_acceptPipe (pPipe=0x9d2a2d0) at pipe.c:459
#3  0xf654028e in vos::OPipe::accept (this=0xf4b74e2c,
Connection=@0xf4b74e40) at refobj.inl:99
#4  0x0806f7bd in desktop::OfficeIPCThread::run (this=0xf4b74e18) at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/desktop/source/app/officeipcthread.cxx:533
#5  0xf6539db2 in vos::_cpp_OThread_WorkerFunction (pthis=0xf4b74e18)
at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/thread.cxx:89
#6  0xf6539d97 in _OThread_WorkerFunction (pthis=0xfffffe00) at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/thread.cxx:75
#7  0xf630d4ef in osl_thread_start_Impl (pData=0x9d29c40) at thread.c:305
#8  0x00cd898c in start_thread () from /lib/tls/libpthread.so.0
#9  0x00a777da in clone () from /lib/tls/libc.so.6

Thread 4 (Thread -202581072 (LWP 8420)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00cdbb15 in pthread_cond_timedwait@@GLIBC_2.3.2 () from
/lib/tls/libpthread.so.0
#2  0xf6309ef7 in osl_waitCondition (Condition=0x9d346e0,
pTimeout=0xf3ecd9f0) at conditn.c:297
#3  0xf65333fd in vos::OCondition::wait (this=0xfffffffc,
pTimeout=0xfffffffc) at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/conditn.cxx:104
#4  0xf653d410 in vos::OTimerManager::run (this=0xf3ed3d20) at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/timer.cxx:523
#5  0xf6539db2 in vos::_cpp_OThread_WorkerFunction (pthis=0xf3ed3d20)
at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/thread.cxx:89
#6  0xf6539d97 in _OThread_WorkerFunction (pthis=0xfffffffc) at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/thread.cxx:75
#7  0xf630d4ef in osl_thread_start_Impl (pData=0x9d34730) at thread.c:305
#8  0x00cd898c in start_thread () from /lib/tls/libpthread.so.0
#9  0x00a777da in clone () from /lib/tls/libc.so.6

Thread 3 (Thread -253437008 (LWP 8423)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00a6e057 in poll () from /lib/tls/libc.so.6
#2  0xf0e6a855 in x11::SelectionManager::dispatchEvent
(this=0xf2bcb490, millisec=-4) at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/dtrans/source/X11/X11_selection.cxx:3585
#3  0xf0e6a9c7 in x11::SelectionManager::run (pThis=0xf2bcb490) at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/dtrans/source/X11/X11_selection.cxx:3630
#4  0xf630d4ef in osl_thread_start_Impl (pData=0x9dd3af0) at thread.c:305
#5  0x00cd898c in start_thread () from /lib/tls/libpthread.so.0
#6  0x00a777da in clone () from /lib/tls/libc.so.6

Thread 2 (Thread -284927056 (LWP 8427)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00a6e057 in poll () from /lib/tls/libc.so.6
#2  0x00c18156 in g_main_loop_get_context () from
/usr/lib/libglib-2.0.so.0
#3  0x00c17590 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#4  0x00c17c53 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#5  0x00924cd2 in link_thread_io_context () from /usr/lib/libORBit-2.so.0
#6  0x00c311bd in g_static_private_free () from /usr/lib/libglib-2.0.so.0
#7  0x00cd898c in start_thread () from /lib/tls/libpthread.so.0
#8  0x00a777da in clone () from /lib/tls/libc.so.6

Thread 1 (Thread -177818240 (LWP 8402)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00cde1ab in __read_nocancel () from /lib/tls/libpthread.so.0
#2  0xee62e38d in ?? () from /usr/lib/libfam.so.0
#3  0x00000028 in ?? ()
#4  0xfeecc850 in ?? ()
#5  0x00000004 in ?? ()
#6  0x00000406 in ?? ()
#7  0x00000406 in ?? ()
#8  0x00000000 in ?? ()
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
-------------------------------------------------------------------
[root@cs5 root]# strace -p `pidof soffice.bin`
Process 8402 attached - interrupt to quit
read(40, strace -p `pidof soffice.bin`
--------------------------------------------------------------------

after passing the export command I see multiple pid's for one instance
of soffice.

With regars to attaching a file that causes the crash, it now crashes
when i start a new spreadsheet, and going to "File Save As". I don't
have to open up any other documents first.

I am going to reboot my system, and see if it exhibits the same behaviour.

Any idea's what to do next?
Comment 12 Douglas Furlong 2004-11-12 08:48:03 EST
I have just rebooted the system, on opening up a new spreadsheet, I
was able to go and receive the "File Save As" dialogue, however, when
I then went to open an old spreadsheet, and then choose "Save As" the
system locks, so it looks like it MAY be related to a particular file,
or group of files.

Here is the output of gdb again...

----------------------------------------------------------------------
(gdb) t a a bt
 
Thread 5 (Thread -189482064 (LWP 2884)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00cde3b8 in accept () from /lib/tls/libpthread.so.0
#2  0xf631850a in osl_acceptPipe (pPipe=0x8faf3f0) at pipe.c:459
#3  0xf654028e in vos::OPipe::accept (this=0xf4b74fbc,
Connection=@0xf4b74fd0) at refobj.inl:99
#4  0x0806f7bd in desktop::OfficeIPCThread::run (this=0xf4b74fa8)
    at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/desktop/source/app/officeipcthread.cxx:533
#5  0xf6539db2 in vos::_cpp_OThread_WorkerFunction (pthis=0xf4b74fa8)
    at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/thread.cxx:89
#6  0xf6539d97 in _OThread_WorkerFunction (pthis=0xfffffe00)
    at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/thread.cxx:75
#7  0xf630d4ef in osl_thread_start_Impl (pData=0x8faed90) at thread.c:305
#8  0x00cd898c in start_thread () from /lib/tls/libpthread.so.0
#9  0x00a777da in clone () from /lib/tls/libc.so.6
 
Thread 4 (Thread -202581072 (LWP 2885)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00cdbb15 in pthread_cond_timedwait@@GLIBC_2.3.2 () from
/lib/tls/libpthread.so.0
#2  0xf6309ef7 in osl_waitCondition (Condition=0x8fb9830,
pTimeout=0xf3ecd9f0) at conditn.c:297
#3  0xf65333fd in vos::OCondition::wait (this=0xfffffffc,
pTimeout=0xfffffffc)
    at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/conditn.cxx:104
#4  0xf653d410 in vos::OTimerManager::run (this=0xf3f37218) at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/timer.cxx:523
#5  0xf6539db2 in vos::_cpp_OThread_WorkerFunction (pthis=0xf3f37218)
    at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/thread.cxx:89
#6  0xf6539d97 in _OThread_WorkerFunction (pthis=0xfffffffc)
    at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/vos/source/thread.cxx:75
#7  0xf630d4ef in osl_thread_start_Impl (pData=0x8fb9880) at thread.c:305
#8  0x00cd898c in start_thread () from /lib/tls/libpthread.so.0
#9  0x00a777da in clone () from /lib/tls/libc.so.6
 
Thread 3 (Thread -253490256 (LWP 2888)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00a6e057 in poll () from /lib/tls/libc.so.6
#2  0xf0e5d855 in x11::SelectionManager::dispatchEvent
(this=0xf2c446d0, millisec=-4)
    at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/dtrans/source/X11/X11_selection.cxx:3585
#3  0xf0e5d9c7 in x11::SelectionManager::run (pThis=0xf2c446d0)
    at
/usr/src/debug/ooo-build-cvs20041001/build/OOO_1_1_2/dtrans/source/X11/X11_selection.cxx:3630
#4  0xf630d4ef in osl_thread_start_Impl (pData=0x90590f8) at thread.c:305
#5  0x00cd898c in start_thread () from /lib/tls/libpthread.so.0
#6  0x00a777da in clone () from /lib/tls/libc.so.6
 
Thread 2 (Thread -291484752 (LWP 2890)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00a6e057 in poll () from /lib/tls/libc.so.6
#2  0x00c18156 in g_main_loop_get_context () from
/usr/lib/libglib-2.0.so.0
#3  0x00c17590 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#4  0x00c#5  0x00924cd2 in link_thread_io_context () from
/usr/lib/libORBit-2.so.0
#6  0x00c311bd in g_static_private_free () from /usr/lib/libglib-2.0.so.0
#7  0x00cd898c in start_thread () from /lib/tls/libpthread.so.0
#8  0x00a777da in clone () from /lib/tls/libc.so.6
 
Thread 1 (Thread -177818240 (LWP 2867)):
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00cde1ab in __read_nocancel () from /lib/tls/libpthread.so.0
#2  0xedfed38d in ?? () from /usr/lib/libfam.so.0
#3  0x00000028 in ?? ()
#4  0xfeeb5040 in ?? ()
#5  0x00000004 in ?? ()
#6  0x00000406 in ?? ()
#7  0x00000406 in ?? ()
#8  0x00000000 in ?? ()
#0  0x009a37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
17c53 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
-----------------------------------------------------------------

[root@cs5 root]# strace -p `pidof soffice.bin`
Process 2867 attached - interrupt to quit
read(40,


I am guessing you REALLY need to see that file don'tcha :\

I'll talk to my boss to see if I can get that resolved (most likely
private email).

Doug
Comment 13 Caolan McNamara 2005-01-12 08:16:07 EST
was this in a gnome or kde environment ?
Comment 14 Douglas Furlong 2005-01-12 10:59:34 EST
It was a gnome ennvironment, both 2.6 and 2.8.

However I no work for this company so providing additional trouble shooting
information, will be troublesome to say the least.
Comment 15 Caolan McNamara 2005-01-27 07:56:02 EST
We never could reproduce this. 1.1.3 is available in fc3-updates and rawhide, so
if it can be reproduced by anyone
Comment 16 Caolan McNamara 2005-01-27 07:56:47 EST
then we'll reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.