Bug 123002 - screen avc denies
Summary: screen avc denies
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: policy   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-11 08:36 UTC by Leonard den Ottolander
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 12:36:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
policy-screen.patch (367 bytes, patch)
2004-05-12 14:28 UTC, Tim Waugh
no flags Details | Diff

Description Leonard den Ottolander 2004-05-11 08:36:42 UTC
policy-1.11.3-3, permissive mode

Running screen as user causes the following denies:
May 11 10:34:08 a3aan kernel: audit(1084264448.257:0): avc:  denied  {
execute } for  pid=2683 exe=/usr/bin/screen name=utempter dev=hda2
ino=27698 scontext=user_u:user_r:user_screen_t
tcontext=system_u:object_r:utempter_exec_t tclass=file
May 11 10:34:08 a3aan kernel: audit(1084264448.258:0): avc:  denied  {
execute_no_trans } for  pid=2683 exe=/usr/bin/screen
path=/usr/sbin/utempter dev=hda2 ino=27698
scontext=user_u:user_r:user_screen_t
tcontext=system_u:object_r:utempter_exec_t tclass=file
May 11 10:34:08 a3aan kernel: audit(1084264448.258:0): avc:  denied  {
read } for  pid=2683 exe=/usr/bin/screen path=/usr/sbin/utempter
dev=hda2 ino=27698 scontext=user_u:user_r:user_screen_t
tcontext=system_u:object_r:utempter_exec_t tclass=file
May 11 10:34:08 a3aan kernel: audit(1084264448.298:0): avc:  denied  {
search } for  pid=2683 exe=/usr/sbin/utempter name=log dev=hda2
ino=388629 scontext=user_u:user_r:user_screen_t
tcontext=system_u:object_r:var_log_t tclass=dir
May 11 10:34:08 a3aan kernel: audit(1084264448.300:0): avc:  denied  {
write } for  pid=2683 exe=/usr/sbin/utempter name=wtmp dev=hda2
ino=390201 scontext=user_u:user_r:user_screen_t
tcontext=system_u:object_r:wtmp_t tclass=file
May 11 10:34:08 a3aan kernel: audit(1084264448.301:0): avc:  denied  {
lock } for  pid=2683 exe=/usr/sbin/utempter path=/var/log/wtmp
dev=hda2 ino=390201 scontext=user_u:user_r:user_screen_t
tcontext=system_u:object_r:wtmp_t tclass=file

Comment 1 Tim Waugh 2004-05-12 14:28:11 UTC
Created attachment 100181 [details]
policy-screen.patch

Even if screen is allowed to execute utempter, utempter fails because it can't
read/write ptmx devices.  So I think this should be a dontaudit.

Comment 2 Daniel Walsh 2004-06-02 18:54:21 UTC
Fixed in selinux-policy-strict-1.13.2-7


Comment 3 Daniel Walsh 2004-07-20 12:36:06 UTC
Fixed in Rawhide


Note You need to log in before you can comment on or make changes to this bug.