Bug 123009 - bluetooth - Can't init device hci0 during boot sequence
bluetooth - Can't init device hci0 during boot sequence
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-11 05:50 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 01:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-05-11 05:50:19 EDT
Description of problem:
 On boot, a part of my bluetooth does not get started.

May 11 03:53:13 hoho2 hcid[2165]: Can't init device hci0. Permission
denied(13)

Version-Release number of selected component (if applicable):
  FC2(T3)

How reproducible:

 Currently booting with 'selinux=1 enforcing=1' as boot parameters.

I will try booting with those parameters off to see what messages are
written.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Below is an extract from /var/log/messages after boot

May 11 03:53:13 hoho2 kernel: SELinux: initialized (dev , type
rpc_pipefs), uses genfs_contexts
May 11 03:53:13 hoho2 rpcidmapd: rpc.idmapd startup succeeded
May 11 03:53:13 hoho2 random: Initializing random number generator: 
succeeded
May 11 03:53:13 hoho2 rc: Starting pcmcia:  succeeded
May 11 03:53:13 hoho2 hcid[2156]: HCI daemon ver 2.4 started
May 11 03:53:13 hoho2 bluetooth: hcid startup succeeded
May 11 03:53:13 hoho2 bluetooth: sdpd startup succeeded
May 11 03:53:13 hoho2 kernel: audit(1084265593.556:0): avc:  denied  {
create }
for  pid=2164 exe=/bin/rfcomm scontext=system_u:system_r:initrc_t
tcontext=system_u:system_r:initrc_t tclass=socket
May 11 03:53:13 hoho2 kernel: audit(1084265593.561:0): avc:  denied  {
net_admin } for  pid=2165 exe=/usr/sbin/hcid capability=12
scontext=system_u:system_r:bluetooth_t
tcontext=system_u:system_r:bluetooth_t tclass=capability
May 11 03:53:13 hoho2 hcid[2165]: Can't init device hci0. Permission
denied(13)
May 11 03:53:13 hoho2 kernel: Bluetooth: L2CAP ver 2.1
May 11 03:53:13 hoho2 kernel: Bluetooth: L2CAP socket layer initialized
May 11 03:53:13 hoho2 sdpd[2160]: sdpd v1.5 started
May 11 03:53:13 hoho2 kernel: Bluetooth: RFCOMM ver 1.2
May 11 03:53:13 hoho2 kernel: Bluetooth: RFCOMM socket layer initialized
May 11 03:53:13 hoho2 kernel: Bluetooth: RFCOMM TTY layer initialized
May 11 03:53:13 hoho2 kernel: nfs warning: mount version older than kernel
May 11 03:53:13 hoho2 kernel: SELinux: initialized (dev 0:11, type
nfs), uses ge:


Expected results:

 no audit denied

Additional info:

 system is FC2(T3) up to date as of now

  On shutdown, there is a message that it could not shutdown RFCOMM
Comment 1 Bob Gustafson 2004-05-11 06:11:36 EDT
The corresponding boot sequence messages when boot paramters
are:'selinux=0 enforcing=0' is:

May 11 04:54:12 hoho2 hcid[2319]: HCI daemon ver 2.4 started
May 11 04:54:12 hoho2 bluetooth: hcid startup succeeded
May 11 04:54:12 hoho2 hcid[2319]: HCI dev 0 up
May 11 04:54:12 hoho2 hcid[2319]: Starting security manager 0
May 11 04:54:12 hoho2 bluetooth: sdpd startup succeeded
May 11 04:54:12 hoho2 kernel: Bluetooth: L2CAP ver 2.1
May 11 04:54:12 hoho2 kernel: Bluetooth: L2CAP socket layer initialized
May 11 04:54:12 hoho2 sdpd[2325]: sdpd v1.5 started
May 11 04:54:12 hoho2 kernel: Bluetooth: RFCOMM ver 1.2
May 11 04:54:12 hoho2 kernel: Bluetooth: RFCOMM socket layer initialized
May 11 04:54:12 hoho2 kernel: Bluetooth: RFCOMM TTY layer initialized
May 11 04:54:13 hoho2 kernel: nfs warning: mount version older than kernel

Comment 2 Daniel Walsh 2004-05-21 08:54:36 EDT
Why is rfcomm in /bin instead of /usr/bin?

Dan
Comment 3 Bob Gustafson 2004-05-25 01:46:07 EDT
Seems to be fixed

Plug in dongle - see below in /var/log/messages:

May 25 00:33:11 hoho2 kernel: usb 3-2: new full speed USB device using
address 2May 25 00:33:12 hoho2 kernel: Bluetooth: Core ver 2.4
May 25 00:33:12 hoho2 kernel: NET: Registered protocol family 31
May 25 00:33:12 hoho2 kernel: Bluetooth: HCI device and connection
manager initialized
May 25 00:33:12 hoho2 kernel: Bluetooth: HCI socket layer initialized
May 25 00:33:12 hoho2 kernel: Bluetooth: HCI USB driver ver 2.5
May 25 00:33:12 hoho2 kernel: usbcore: registered new driver hci_usb

Unplug dongle - does not crash (see /var/log/messages below)

May 25 00:37:22 hoho2 kernel: usb 3-2: USB disconnect, address 2

-----

Now I can try to connect with my cell phone....

---- This is with FC2, updated as shown below

[root@hoho2 root]# date
Tue May 25 00:09:05 CDT 2004
[root@hoho2 root]# yum --exclude=ppp --exclude=subversion update \*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - Development Tree
Server: Fedora Core 2 - i386 - Released Updates
Server: Fedora Core 2 - i386 - Unreleased Updates
Finding updated packages
Downloading needed headers
No Packages Available for Update
No actions to take



Note You need to log in before you can comment on or make changes to this bug.