Bug 123028 - 32bit UID & GID's get mapped to 65534
32bit UID & GID's get mapped to 65534
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-11 10:42 EDT by Panu Matilainen
Modified: 2013-08-05 21:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 00:31:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix 32bit UID's (1.58 KB, patch)
2004-05-11 10:45 EDT, Panu Matilainen
no flags Details | Diff

  None (edit)
Description Panu Matilainen 2004-05-11 10:42:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4)
Gecko/20030922

Description of problem:
On RHEL 3 x86_64 all 32bit UID's and GID's map to 65534, regardless of
filesystem type. See http://www.x86-64.org/lists/discuss/msg04027.html
for more discussion on the topic.

Version-Release number of selected component (if applicable):
kernel-2.4.21, all releases

How reproducible:
Always

Steps to Reproduce:
1. touch foo
2. chown 11223344 foo
3. ls -l foo
    

Actual Results:  ls shows it's owned by nfsnobody (uid 65534)

Expected Results:  The owner should change to uid 11223344.

Additional info:
Comment 1 Panu Matilainen 2004-05-11 10:45:07 EDT
Created attachment 100151 [details]
Patch to fix 32bit UID's

Patch fetched from the URL above and rediffed against 2.4.21-9.0.3.EL sources.
Fixes the problem for me.
Comment 2 Ernie Petrides 2004-05-11 14:52:32 EDT

*** This bug has been marked as a duplicate of 117435 ***
Comment 3 John Flanagan 2004-09-02 00:31:32 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.