Bug 123054 - Enabling winbind creates a bad /etc/pam.d/system-auth file
Summary: Enabling winbind creates a bad /etc/pam.d/system-auth file
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-11 20:52 UTC by Jay Fenlason
Modified: 2014-08-31 23:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 23:34:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smb.conf from the domain member (800 bytes, text/plain)
2004-05-11 20:53 UTC, Jay Fenlason
no flags Details
diff between system-config-authentication generated /etc/pam.d/system-auth and my working one (819 bytes, text/plain)
2004-05-11 20:56 UTC, Jay Fenlason
no flags Details

Description Jay Fenlason 2004-05-11 20:52:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
I attempted to configure Samba with winbindd support to test a new
Samba version.  (See attached /etc/samba/smb.conf)  I could not log in
using a domain user (SMBDVL1\devel1).  After poking around, I found
that making the attached change to /etc/pam.d/system-auth allowed
domain and local users to log in

Version-Release number of selected component (if applicable):
authconfig-gtk-4.6.2-1

How reproducible:
Always

Steps to Reproduce:
1.run system-config-authentication, choose Enable Winbind
2.Try to log in as a domain user
3.login is refused, even though password is correct.
    

Additional info:

Comment 1 Jay Fenlason 2004-05-11 20:53:55 UTC
Created attachment 100165 [details]
smb.conf from the domain member

Comment 2 Jay Fenlason 2004-05-11 20:56:07 UTC
Created attachment 100166 [details]
diff between system-config-authentication generated /etc/pam.d/system-auth and my working one

Comment 3 Nalin Dahyabhai 2004-05-11 21:30:13 UTC
Jay, are you sure that's right?  The unix account management step
isn't causing any login failures on my system.  What kind of failure
message are you getting?


Note You need to log in before you can comment on or make changes to this bug.