Bug 123090 - ifenslave binary does not function - package needs rebuilding
ifenslave binary does not function - package needs rebuilding
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iputils (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 04:51 EDT by Reuben Farrelly
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 08:55:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2004-05-12 04:51:54 EDT
Description of problem:

This package needs to rebuilt as the ifenslave binary no longer 
works.  This appears to have been caused by the kernel headers 
changing but the binary not being rebuild against the new headers 
recently (since Feb 17th)

Version-Release number of selected component (if applicable):

iputils-20020927-13  (current Fedora/Rawhide release)

How reproducible:

Always.

Steps to Reproduce:
1. Set bonding parameters as documented in kernel source
2. Reboot system - does not accept parameters
3.
  
Actual results:

iputils-20020927-13

Expected results:

logged in /var/log/messages:
May 12 18:12:23 tornado ifup: Something broke getting the master's IP 
address: Cannot assign requested address.
May 12 18:12:23 tornado ifup: Something broke getting the master's 
destination address: Cannot assign requested address.
May 12 18:12:23 tornado ifup: Something broke getting the master's 
broadcast address: Cannot assign requested address.
May 12 18:12:23 tornado ifup: Something broke getting the master's 
netmask: Cannot assign requested address.
May 12 18:12:23 tornado ifup: Something broke setting the slave's 
address: Invalid argument.
May 12 18:12:23 tornado ifup: Error setting the slave (eth1) with 
SIOCSIFDSTADDR: Invalid argument.

Bonding would be set up and function

Additional info:

Workaround was to rebuild against current headers (2.6.6), ifenslave 
worked fine and system booted up without error.

It's a simple request and is easily fixable - can this bug please be 
resolved before the final freeze?
Comment 1 Reuben Farrelly 2004-05-21 08:55:14 EDT
Seems to be fixed now, package has been rebuild in the last day or so 
and binary is now built against correct headers.

Note You need to log in before you can comment on or make changes to this bug.