Bug 123117 - Memory Leak: 600MB gone overnight on idle machine
Memory Leak: 600MB gone overnight on idle machine
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: slocate (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 13:00 EDT by Christopher Heiny
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-18 07:57:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tuesday evening xosview screen capture (9.44 KB, image/png)
2004-05-12 13:01 EDT, Christopher Heiny
no flags Details
Wednesday morning xosview screen capture. (9.01 KB, image/png)
2004-05-12 13:02 EDT, Christopher Heiny
no flags Details
Wednesday morning ps -aux output. (7.01 KB, text/plain)
2004-05-12 13:03 EDT, Christopher Heiny
no flags Details
Wednesday evening xosview capture. (8.49 KB, image/png)
2004-05-13 12:55 EDT, Christopher Heiny
no flags Details
Thursday morning xosview screen capture. (8.43 KB, image/png)
2004-05-13 12:57 EDT, Christopher Heiny
no flags Details
ps -aux output from Wednesday night. (6.65 KB, text/plain)
2004-05-13 12:58 EDT, Christopher Heiny
no flags Details
ps -aux from Thursday morning. (6.17 KB, text/plain)
2004-05-13 12:58 EDT, Christopher Heiny
no flags Details

  None (edit)
Description Christopher Heiny 2004-05-12 13:00:54 EDT
Description of problem: Where has all my RAM gone? Something on an
idle machine eats up 600M of memory overnight.


Version-Release number of selected component (if applicable): FC2 test 3


How reproducible: Always


Steps to Reproduce:
1. Install FC2 test 3
2. Login to KDE.
3. Add kweatherstation to the toolbar, use engine as screensaver
4. Reboot
5. Login to KDE.  Start xosview.
6. Leave system otherwise unused for several hours.
7. Upon return, you will find something has sucked up vast quantities
of RAM.
  
Actual results: Upon return, you will find something has sucked up
vast quantities of RAM.


Expected results: RAM should be available for me to use.


Additional info: Files to be attached shortly - Tuesday evening
xosview snapshot, Wednesday morning xosview snapshot, Wednesday
morning ps -auxw output.  (managed to lose the Tuesday evening ps -aux
(doh!) - will repeat tonight and attach Wed eve/Thurs morning tomorrow).
Comment 1 Christopher Heiny 2004-05-12 13:01:33 EDT
Created attachment 100192 [details]
Tuesday evening xosview screen capture
Comment 2 Christopher Heiny 2004-05-12 13:02:01 EDT
Created attachment 100193 [details]
Wednesday morning xosview screen capture.
Comment 3 Christopher Heiny 2004-05-12 13:03:09 EDT
Created attachment 100194 [details]
Wednesday morning ps -aux output.

As mentioned previously, Tuesday evening ps -aux was lost.  Will reproduce and
attach tomorrow.  Hopefully this will help you get started.
Comment 4 Christopher Heiny 2004-05-13 12:53:34 EDT
OK, managed not to stomp on my own foot this time, and will be
attaching a full set of snapshots and ps -aux output.  I don't spot
any obvious culprit, but someone, somewhere, has scarfed up several
hundred MB of RAM...
Comment 5 Christopher Heiny 2004-05-13 12:55:22 EDT
Created attachment 100214 [details]
Wednesday evening xosview capture.

Like the Tuesday evening capture, this was done right after a system reboot and
login to KDE.
Comment 6 Christopher Heiny 2004-05-13 12:57:25 EDT
Created attachment 100215 [details]
Thursday morning xosview screen capture.

This was captured first thing Thursday AM.  Only user interactions from
Wednesday night to Thursday morning was the two screen captures.
Comment 7 Christopher Heiny 2004-05-13 12:58:04 EDT
Created attachment 100216 [details]
ps -aux output from Wednesday night.
Comment 8 Christopher Heiny 2004-05-13 12:58:37 EDT
Created attachment 100217 [details]
ps -aux from Thursday morning.
Comment 9 Ngo Than 2004-05-13 15:08:46 EDT
Hm, i'm not sure that this problem is in KDE. There're many daemons
and applications running on your machine, that could cause this problem.

I have a machine running with KDE-3.2 since 2 weeks, i don't see this
issue here.

does this problem still show up, if you disable screensaver?

Please try to login in GNOME and looks if this problem also appears here!
Comment 10 Christopher Heiny 2004-05-13 15:50:12 EDT
I'm fairly sure it's not KDE, too, but had no idea at all where to 
file it.  If you have a better suggestion, I won't argue if you 
transfer the bug to that component. 
 
I originally suspected one of the daemons, but none of them appear 
to be getting particularly large in terms of report memory usage.  
Some of the KDE apps appear unusually huge (like the weather 
station), so it was the closest thing I had to a suspect. 
 
I'll have to fix the Gnome login crash to try that alternative. 
 
Tonight I will try disabling screensaver to see if that changes 
anything (can't do much during the workday, because I'm actually 
using the system). 
Comment 11 Christopher Heiny 2004-05-19 13:53:48 EDT
Sorry about the delay.  Tried it Monday night with the screen saver
disabled, and last night with just the login screen, and still lost a
huge amount of memory.  I'm using the KDE login screen, however this
is a good indication that Ngo is correct in surmising in Comment #9
that it isn't KDE.

There was a slight difference in the login screen only case, in that
there was greater proportion of cache in the allocation than
previously, but still nearly the entirety of real RAM was allocated.

Realized that the system is NOT totally idle overnight - there's still
some cron jobs that run.  I'm going to turn them off one by one to see
if one of them is the culprit. 
Comment 12 Christopher Heiny 2004-05-19 15:12:03 EDT
Aha!  A Clew!

Anaconda, for no apparent good reason, decided to run slocate a few
moments ago.  Memory usage went through the roof. and now sits at 1G.
 Oddly enough, all that memory remains allocated even after killing
slocate/awk/updatedb.

I'll deactivate the slocate cron job tonight, and see if the same
thing happens.
Comment 13 Christopher Heiny 2004-06-04 16:18:03 EDT
OK, it was anacron, not anaconda that ran slocate.  After paring the
crontab entries down, it appears that FC2T3 slocate was the culprit. 
I have since updated to FC2 release, and the problem has not returned.

I've switched this to slocate, since that seemed to be the cause. 
However, it's OK resolve with
whatever-Fedora-uses-for-can't-reproduce, since I no longer am able to
reproduce it.

Note You need to log in before you can comment on or make changes to this bug.