Bug 123168 - No openoffice.org x86_64 packages, i386 do not work.
No openoffice.org x86_64 packages, i386 do not work.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: dff
:
: 123506 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-13 10:43 EDT by Terje Røsten
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-23 14:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Røsten 2004-05-13 10:43:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:

Is it correct that the x86_64 build of openoffice.org is disabled?

I only find i386 packages on RHN.

However the i386 packages cannot be installed on x86_64, because only
x86_64 or i386 version of libart_lgpl can be installed on the system.
GNOME wants libart_lgpl x86_64, while openoffice.org wants ibart_lgpl
i386.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-16.7.EL

How reproducible:
Always

Steps to Reproduce:
Try to upgrade the openoffice package to version 1.1.0-16.7.EL on a
x86_64 box.
Comment 1 Dan Williams 2004-05-13 11:08:29 EDT
There are as yet no 64-bit builds of OpenOffice.org since OOo is not
yet 64-bit clean.  That's coming in the future.

WRT the libart_lgpl problem, that was supposed to be fixed by an
up2date fix.  Could you attempt to manually quit up2date and restart
it, or to restart your computer and try to run up2date again?

Thanks,
Dan
Comment 2 Terje Røsten 2004-05-13 11:24:31 EDT
I have now removed the openoffice packages from the system, to let
up2date exit cleanly, it's server anyway.

But if I now try to install openoffice with up2date -i openoffice, I
get this:


Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
openoffice                              1.0.2          8             
   i386  

Testing package set / solving RPM inter-dependencies...
########################################
openoffice-1.0.2-8.i386.rpm ########################## Done.         
         
There was a package dependency problem. The message was:
Dependencies should have already been resolved, but they are not.

If I try to install the new openoffice.org package I get this error:
Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
openoffice.org                          1.1.0          16.7.EL       
   i386  


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
openoffice.org-libs  1.1.0-16.7.EL       requires libart_lgpl_2.so.2

up2date version:

$ rpm -q up2date
up2date-4.2.14-1

Comment 3 Dan Williams 2004-05-13 11:44:43 EDT
Ok, seems that the problem is that the libart_lgpl i386 packages are
not in the x86_64 channel quite yet...

Donald, can you knock some heads?  johnf said the request has been in
since last week to get these type of packages into the channel.
Comment 4 Chuck Mead 2004-05-17 10:52:21 EDT
This appears to be a problem with FC2T3 as well.
Comment 5 Suzanne Hillman 2004-05-20 16:27:19 EDT
*** Bug 123506 has been marked as a duplicate of this bug. ***
Comment 6 Terje Røsten 2004-05-23 14:58:03 EDT
libart_lgpl-2.3.11-2 (i386) is now added to the right channel and
openoffice.org-1.1.0-16.7.EL is working. Thanks.

Note You need to log in before you can comment on or make changes to this bug.