Bug 123169 - bmptoppm: Zero byte allocation
bmptoppm: Zero byte allocation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-13 11:13 EDT by Gregory Gulik
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-02 12:04:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Gulik 2004-05-13 11:13:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
When running bmptoppm to convert a valid BMP file to a PPM file the
error "Zero byte allocation" is returned.

Version-Release number of selected component (if applicable):
netpbm-10.19-7
netpbm-progs-10.19-7

How reproducible:
Always

Steps to Reproduce:
1. Create a BMP file
2. Run bmptoppm a.bmp > a.ppm
3.    

Actual Results:  [greg@crashnburn tmp]$ bmptoppm S400_img_2547.bmp > a.ppm
bmptoppm: Windows BMP, 1842x1374x24
bmptoppm: Zero byte allocation


Expected Results:  The file should be converted to a PPM file without
error.  I tried the same file on a Fedora Core 1 system and it worked
without error.

Additional info:

A sample file that produces this error can be found here:
http://www.gagme.com/greg/tmp/S400_img_2547.bmp
Comment 1 Phil Knirsch 2004-07-02 12:04:20 EDT
Found the bug, netpbm-10.22-2 and later will contain the fix.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.