Bug 12319 - RFE:Run cron jobs like makewhatis after newly installed
RFE:Run cron jobs like makewhatis after newly installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Preston Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-16 09:31 EDT by Michael Redinger
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 16:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-06-16 09:31:31 EDT
makewhatis is not built when first starting a newly built system. Therefore
the whatis database is not yet built (see Bug 7547 - marked as resolved).
Since some time (see Bug 1929) makewhatis can be called with -u which only
updates the database but does not rebuild it -u is used for cron.daily, but
not for cron.weekly.
However, this also means that the whatis database is only built when
cron.weekly is run (Sunday). This is quite a lot of time ...

(I did try to run cron.daily/makewhatis twice. No database built. Then I
run cron.weekly/makewhatis which solved the problem).

Quite difficult problem - "run once" as suggested in Bug 7547 (like Windows
or even SuSE)?
Comment 1 Michael Redinger 2000-07-15 13:29:55 EDT
Something similar happens with slocate - see Bug 13611 (but there it's even
worse - the user gets an email from cron that cron.daily/slocate should be run).
Comment 2 Bernhard Rosenkraenzer 2000-08-09 07:58:29 EDT
We should probably add support for something like this to the installer...
Comment 3 Michael Fulbright 2000-09-26 12:09:55 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 4 Michael Fulbright 2000-09-26 12:55:37 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 5 Michael Fulbright 2001-04-11 15:39:27 EDT
This is something the distribution would have to handle on first boot.
Comment 6 Michael Redinger 2001-07-06 07:37:00 EDT
Changing to RESOLVED - CURRENT ...

Note You need to log in before you can comment on or make changes to this bug.