Bug 123305 - nautilus-cd-burner makes bad use of cdrecord for [my?] scsi cd-r/rw device
nautilus-cd-burner makes bad use of cdrecord for [my?] scsi cd-r/rw device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-16 14:34 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 05:01:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-05-16 14:34:42 EDT
Version-Release number of selected component:
nautilus-cd-burner(0:2.6.0-2).i386

How reproducible: Always

Steps to Reproduce:
0. Have an scsi cd-r/rw device.
1. Grab an .iso file. (let's say fc2 disc1 iso file)
2. Click on 'write to cd' in nautilus menu. 
   The nautilus-cd-burner window should pop.
3. Click on the 'write to cd' button.

Actual Results:
I've got an error window with details as follow: 
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
are root.
cdrecord: No such device or address. Cannot open '/dev/pg6'. Cannot
open SCSI driver.
scsibus: 0 target: 6 lun: 0
scsidev: '0,6,0'
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot do mlockall(2).
cdrecord: Continuing in 5 seconds...
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Asuming -tao mode.
cdrecord: No write mode specified.

Additional info:
"cdrecord dev=/dev/cdrom FC2-i386-disc1.iso" does work. But it's far
from being as user friendly as nautilus-cd-burner.

My device is an old plextor 12/4/32:
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: PLEXTOR  Model: CD-R   PX-W124TS Rev: 1.06
  Type:   CD-ROM                           ANSI SCSI revision: 02
Comment 1 Alan Cox 2004-05-21 20:15:57 EDT
This is a mix of two things
1. A kernel bug specific to Fedora with regard to generic devices
2. Nautilus really should be using /dev/cdrom etc anyway
Comment 2 Rick Johnson 2004-05-24 21:42:16 EDT
Adding a me too with both a Plextor Plexwriter 12/10/32 and an HP
CDWriter Plus 9200 series. 

Error is:

cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
are root.
cdrecord: No such device or address. Cannot open '/dev/pg3'. Cannot
open SCSI driver.
scsibus: 0 target: 3 lun: 0
scsidev: '0,3,0'
cdrecord: Continuing in 5 seconds...
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Asuming -tao mode.
cdrecord: No write mode specified.

As an experiment, I attempted to setuid cdrecord to root to ensure it
wasn't just permission related on the device file. 

It would be "nice" if it did use /dev/cdrom as a reference as it should.

My workaround for now is to make an ISO image, then use cdrecord at
the commandline to burn the CD. Not very convenient, but doable until
it's fixed.
Comment 3 Tim Keitt 2004-05-26 17:45:22 EDT
Same result here with Sony DRU-510a. Can someone post the cdrecord
command line? Thanks.
Comment 4 Steffen Mann 2004-05-29 14:50:07 EDT
same for me on nautilus-cd-burner-2.6.01 from fc2.
Got SCSI hd with sda and sdb as well as scsi CD drive plus atapi DVD
burner from LG. 
nautilus-cd-burner will not write to the DVD drive it just sits there
with the progress bar.

I just can cancel the action x-cdroast with ProDVD writes nicely to
the device.

Have Bastien fix the crappy code...
Comment 5 Tim Waugh 2004-08-25 10:10:05 EDT
Using these packages:

cdrecord-2.01.0.a37.99-1
nautilus-cd-burner-2.7.6-1

I get these errors:

cdrecord: Illegal write mode for this drive.
cdrecord: Drive does not support TAO recording.
SCSI buffer size: 64512
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Linux sg driver version: 3.5.27
scsibus: -2 target: -2 lun: -2
devname: '/dev/cdrom'
scsidev: '/dev/cdrom'
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: If you have unexpected problems, please try Linux-2.4 or
Solaris.
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: Warning: Running on Linux-2.6.8-1.526
cdrecord: Continuing in 5 seconds...
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Asuming -tao mode.
cdrecord: No write mode specified.
Comment 6 David Juran 2004-08-27 12:48:24 EDT
This seems like a duplicate of bug 130576
Comment 7 Alexander Larsson 2004-09-15 07:35:37 EDT
I don't have a scsi cdburner, so i have a very hard time debugging this...
Comment 8 Steffen Mann 2004-09-15 07:55:40 EDT
Alex,
you have that on an IDE as well....
Comment 9 Alexander Larsson 2004-09-21 10:10:36 EDT
It works fine on my IDE drives.
Comment 10 Tim Waugh 2004-09-23 06:06:18 EDT
My comment #5 was referring to an IDE drive too (sorry, didn't see
'scsi' in the bug summary).
Comment 11 Alexander Larsson 2004-09-23 11:50:17 EDT
Ok. Can everyone re-try with the latest kernel and nautilus-cd-burner
2.8.3-1. That has quite a few fixes.
Comment 12 Tim Waugh 2004-09-27 13:13:58 EDT
Works here.
Comment 13 Alexander Larsson 2004-09-28 05:01:49 EDT
Then i'll close this. If you have any problem with the latest versions
of anything, open a new bug. This bug already has to many confusing
mixups of various problems.

Note You need to log in before you can comment on or make changes to this bug.