Bug 12331 - Kickstart install fails with Anaconda errors
Kickstart install fails with Anaconda errors
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-16 14:08 EDT by alex
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 13:30:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Kickstart configuration file being used (made by mkkickstart) (1.45 KB, text/plain)
2000-06-16 14:09 EDT, alex
no flags Details

  None (edit)
Description alex 2000-06-16 14:08:28 EDT
Kickstart installs seem to always fail with the following error:

Traceback ((innermost last):
  File "/usr/bin/anaconda", line 45, in ?
    [ 'gui', 'text', 'reconfig', 'test', 'debug',
  File "/usr/lib/anaconda/isys.py", line 198, in getopt
    return apply(_isys.getopt, args)
TypeError: bad argument --kickstart: missing argument

I am booting with the latest boot images from updates.redhat.com, as well
as the updates disk, (linux updates ks), using a kickstart file generated
by mkkickstart and modified to include the "skipx" parameter immediately
after the mouse options, and installing from a CD-ROM.

It detects the SCSI adapter and Ethernet adapters properly, copies the
files from the updates disk, insmods all the FS modules then exits with the
above error and halts.

The system is an intel 1U rackmount, P3-600 Coppermine, 256MB RAM, Adaptec
29160 SCSI Host adapter, 18GB SCSI drive, with 2 EEPRO's.

The Kickstart is setup to get it's network information from DHCP, install
from CD-ROM and install a set of packages generated on the exact machine
using mkkickstart after a manual 6.2 install.
Comment 1 alex 2000-06-16 14:09:32 EDT
Created attachment 498 [details]
The Kickstart configuration file being used (made by mkkickstart)
Comment 2 Brock Organ 2000-06-19 14:04:05 EDT
hmm ... are you running at the syslinux prompt:

linux ks=floppy updates

and using the boot.img (and not bootnet.img) ...?

using this kickstart file w/boot.img from 4/7/2000 and updates from 4/19/2000
works in our test lab ...
Comment 3 alex 2000-06-22 13:26:25 EDT
It may have been a problem with the 2.88MB floppy drive in this system, it 
seems to be tempermental when reading from floppies that work fine on other 
machines.  It seems to have read errors every so often, sometimes resulting in 
ks.cfg not being read at all, sometimes it is read with piles of errors.  It 
also seems to have problems booting every few attempts..

The odd thing is that the updates disk has never failed yet..

At any rate, I can't test on any of the other identical machines, as they are 
without video cards at this time.  If it works with the new boot/updates then 
it's probably safe to assume it was something to do with the floppy drive 
itself.
Comment 4 Brock Organ 2000-06-27 13:30:14 EDT
On your hunch that the floppy drive is flaky I'll resolve this bug ... If you
still have this problem under other circumstances please reopen it ... thank you
for your efforts and for the report!

Note You need to log in before you can comment on or make changes to this bug.