Bug 123338 - siimage IDE unreliable after using hdparm
siimage IDE unreliable after using hdparm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 07:17 EDT by Paul Jakma
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-17 07:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Jakma 2004-05-17 07:17:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Galeon/1.3.10

Description of problem:
Setting IDE driver options with hdparm against a device driven by
siimage IDE driver seems to kill the driver. Particularly, setting -d1
and unsetting it appears to cause problems, after which the disk is no
longer accessible, with IO errors, ide resets, etc:

May 17 00:21:34 edwards kernel: hda: dma_timer_expiry: dma status ==
0x20       
May 17 00:21:34 edwards kernel: hda: DMA timeout retry               
          
May 17 00:21:34 edwards kernel: hda: timeout waiting for DMA         
          
May 17 00:21:34 edwards kernel: hda: status error: status=0x58 {
DriveReady Seek
Complete DataRequest }                                               
          
May 17 00:21:34 edwards kernel:                                      
          
May 17 00:21:34 edwards kernel: hda: drive not ready for command     
          
May 17 00:21:34 edwards kernel: hda: status timeout: status=0xd8 {
Busy }       
May 17 00:21:34 edwards kernel:                                      
          
May 17 00:21:34 edwards kernel: ide0: reset phy, status=0x00000113,
siimage_reset                                                        
                      
May 17 00:21:34 edwards kernel: hda: drive not ready for command     
          
May 17 00:22:09 edwards kernel: ide0: reset timed-out, status=0xd8   
          
May 17 00:22:09 edwards kernel: hda: status timeout: status=0xd8 {
Busy }       
May 17 00:22:09 edwards kernel:                                      
          
May 17 00:22:09 edwards kernel: ide0: reset phy, status=0x00000113,
siimage_reset                                                        
                      
May 17 00:22:09 edwards kernel: hda: drive not ready for command     
          
May 17 00:22:39 edwards kernel: ide0: reset timed-out, status=0xd8   
          
May 17 00:22:39 edwards kernel: end_request: I/O error, dev hda,
sector 95      
May 17 00:22:39 edwards kernel: Buffer I/O error on device hda1,
logical block 4
May 17 00:22:39 edwards kernel: lost page write due to I/O error on hda1  

Hardware is:

Compaq Deskpro 4000N 5233MMX
Silicon Image Sil3112A controller
Western Digital WDC1600 SATA disk drive


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1. hdparm -d1c1u1 /dev/hda
2. boom
3.  
    

Actual Results:  IDE driver dma timeouts and other errors.

Expected Results:  There should have been no immediately observable
results.

Additional info:
Comment 1 Arjan van de Ven 2004-05-17 07:24:22 EDT
I'd seriously recommend against using hdparm for "tweaking" DMA
settings. The kernel autodetects what is optimal AND safe and sets
that; manual overrides can go bang easily...

Note You need to log in before you can comment on or make changes to this bug.