Bug 12334 - Wrong calculation of length of translated strings
Summary: Wrong calculation of length of translated strings
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard: Winston rc1
Keywords:
: 13047 13220 14772 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-16 18:41 UTC by Enrico Scholz
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 12:50:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-06-16 18:41:42 UTC
When choosing another language the english, the length of the string in the upper right corner will be assumed to be the length of the English string.

E.g. the screen "Welcome at Red Hat Linux!", translated in German as "Willkommen bei Red Hat Linux", will show in the upper right corner "Willkom" only (it should be "Willkommen").

Comment 1 Chris Evans 2000-06-26 22:15:13 UTC
Try this in BETA2 for fun!
Select A language other than English to install. Hit forward. Hit back. Choose
another non-English language. Repeat a few times.
Now start the install in English as normal
-> Note how all the text is spaced far too much. The buttons in the GUI are huge
and overlap each other sometimes. A lot of text is overlayed. All very ugly.

Comment 2 Christian Rose 2000-07-01 16:37:46 UTC
*** Bug 13220 has been marked as a duplicate of this bug. ***

Comment 3 Christian Rose 2000-07-13 21:30:45 UTC
This bug is still alive and well in beta3.

Comment 4 Christian Rose 2000-07-23 00:38:25 UTC
This bug is still present in beta4.

Comment 5 Glen Foster 2000-07-31 12:34:35 UTC
This defect is considered MUST-FIX for Winston Release-Candidate #1

Comment 6 Matt Wilson 2000-07-31 12:44:41 UTC
Fix checked in CVS -- QA, please verify fix in next tree.


Comment 7 Matt Wilson 2000-07-31 14:51:47 UTC
*** Bug 14772 has been marked as a duplicate of this bug. ***

Comment 8 Matt Wilson 2000-07-31 18:20:29 UTC
*** Bug 13047 has been marked as a duplicate of this bug. ***

Comment 9 Arenas Belon, Carlo Marcelo 2000-08-02 04:13:44 UTC
there is on pinstripe at least with LANG=es

Comment 10 Matt Wilson 2000-08-04 19:50:54 UTC
Fixed in CVS.


Comment 11 Christian Rose 2000-08-22 12:50:24 UTC
Fix verified in RC2. It now works like it should.

Comment 12 Brock Organ 2000-08-22 20:48:17 UTC
thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.