Bug 123341 - RHEL3 U3 : ia32el cannot work with glibc that uses fast syscalls
Summary: RHEL3 U3 : ia32el cannot work with glibc that uses fast syscalls
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ia32el (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-17 11:49 UTC by Yoav Zach
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version: 1.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 17:50:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
write the address of fast-syscall kernel stub into tls of new threads (4.73 KB, patch)
2004-05-17 11:50 UTC, Yoav Zach
no flags Details | Diff

Description Yoav Zach 2004-05-17 11:49:13 UTC
Description of problem:
when working in a system with fast system calls, ia32el crashes soon 
after the creation of a new thread. this is because libia32x.so fails 
to write the address of the fast-syscall kernel stub into the tls of 
the newly created thread.

Version-Release number of selected component (if applicable):
4600

How reproducible:
run MT 32 bit application on top of ia32el on a system with fast-
syscalls.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
ia32el crashes

Expected results:
ia32el should work correctly

Additional info:

Comment 1 Yoav Zach 2004-05-17 11:50:41 UTC
Created attachment 100268 [details]
write the address of fast-syscall kernel stub into tls of new threads

this patch goes on top of fix_affinity.patch, submitted for bug #123340


Note You need to log in before you can comment on or make changes to this bug.