Bug 123369 - httpd randomly segfaults on x86_64
httpd randomly segfaults on x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 14:59 EDT by Dan Hollis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-17 15:48:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hollis 2004-05-17 14:59:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040421

Description of problem:
httpd randomly segfaults on x86_64. dmesg says:

httpd[943]: segfault at 0000002a9a3ec9d0 rip 0000002a9a3ec9d0 rsp
0000007fbffffb88 error 14

Version-Release number of selected component (if applicable):
httpd-2.0.49-4

How reproducible:
Always

Steps to Reproduce:
1.install FC2 test3 on x86
2.start up httpd
3.watch it run for a few days
    

Actual Results:  Randomly segfaults

Expected Results:  Shouldnt segfault

Additional info:

x86_64 specific?
Comment 1 Joe Orton 2004-05-17 15:05:06 EDT
Please do:

echo CoreDumpDirectory /tmp > /etc/httpd/conf.d/core.conf

restart the server, and collect some core files in /tmp.

You get a message in error_log for each child process core dump; if
you can correlate that with a particular request in access_log that
would help.  What modules are in use on the site?
Comment 2 Dan Hollis 2004-05-17 15:30:59 EDT
apache config is 100% stock out of the box untouched and pristine.

i narrowed it down to the kill -USR1 being done on daily logrotates.
100% repeatable.

i have a couple cores, heres what the backtrace says in them:

gdb   /usr/sbin/httpd core.21146
(gdb) bt
#0  0x0000002a9a3ec9d0 in ?? ()
#1  0x0000002a9567f1f0 in regfree () from /usr/lib64/libpcreposix.so.0
#2  0x000000552aacda59 in ap_is_matchexp () from /usr/sbin/httpd
#3  0x0000002a95df6f2d in apr_pool_cleanup_run () from
/usr/lib64/libapr-0.so.0
#4  0x0000002a95df669d in apr_pool_destroy () from
/usr/lib64/libapr-0.so.0
#5  0x0000002a95df674e in apr_pool_destroy () from
/usr/lib64/libapr-0.so.0
#6  0x000000552aacb89b in ap_run_error_log () from /usr/sbin/httpd
#7  0x000000552aacc2fa in main () from /usr/sbin/httpd

gdb   /usr/sbin/httpd core.21188
(gdb) bt
#0  0x0000002a9a3ec9d0 in ?? ()
#1  0x0000002a9567f1f0 in regfree () from /usr/lib64/libpcreposix.so.0
#2  0x000000552aacda59 in ap_is_matchexp () from /usr/sbin/httpd
#3  0x0000002a95df6f2d in apr_pool_cleanup_run () from
/usr/lib64/libapr-0.so.0
#4  0x0000002a95df660b in apr_pool_clear () from /usr/lib64/libapr-0.so.0
#5  0x000000552aacc1dd in main () from /usr/sbin/httpd
Comment 3 Joe Orton 2004-05-17 15:33:07 EDT
Are you running a non-Red Hat-packaged php 4.3.[56]?
Comment 4 Dan Hollis 2004-05-17 15:43:36 EDT
Name        : php                          Relocations: (not relocatable)
Version     : 4.3.6                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Fri 16 Apr
2004 08:36:26 AM PDT
Install Date: Sun 18 Apr 2004 03:30:01 AM PDT      Build Host:
dolly.build.redhat.com
Group       : Development/Languages         Source RPM:
php-4.3.6-1.src.rpm
Size        : 7416014                          License: The PHP License
Signature   : DSA/SHA1, Fri 16 Apr 2004 11:33:39 AM PDT, Key ID
da84cbd430c9ecf8
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Comment 5 Joe Orton 2004-05-17 15:48:12 EDT
Ah, that one was withdrawn from FC2 because it causes segfaults on
restart. Either downgrade to the 4.3.4 packages, find 4.3.6-2 or later
if it's in Raw Hide, or rebuild with this patch applied: 
http://www.apache.org/~jorton/php-4.3.6-pcrealloc.patch

We've got 4.3.6 packages queued for an FC2 update which will not
suffer from this bug.
Comment 6 Dan Hollis 2004-05-17 15:58:40 EDT
yeah php 4.3.4-11.x86_64 seems to have fixed it

Note You need to log in before you can comment on or make changes to this bug.